dev-python/setuptools-git: Enable py3.8
authorMichał Górny <mgorny@gentoo.org>
Tue, 19 Nov 2019 09:01:48 +0000 (10:01 +0100)
committerMichał Górny <mgorny@gentoo.org>
Tue, 19 Nov 2019 09:05:08 +0000 (10:05 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/setuptools-git/setuptools-git-1.2.ebuild

index 28a24814fe38e0daf63f1303f574921336aa36b6..2bc70bc711f774da1b888cb93b6c9c8e7049d5bf 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy{,3} )
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
 
 inherit distutils-r1
 
@@ -15,12 +15,11 @@ SLOT="0"
 KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sparc x86"
 
 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
-                dev-vcs/git"
+       dev-vcs/git"
 RDEPEND="${DEPEND}"
 
 python_test() {
        git config --global user.name "test user" || die
        git config --global user.email "test@email.com" || die
        esetup.py test
-       retr=$?
 }