dev-haskell/editline: fix build against ncurses[tinfo], bug #689988
authorSergei Trofimovich <slyfox@gentoo.org>
Fri, 19 Jul 2019 07:02:41 +0000 (08:02 +0100)
committerSergei Trofimovich <slyfox@gentoo.org>
Fri, 19 Jul 2019 07:03:40 +0000 (08:03 +0100)
Reported-by: Toralf Förster
Closes: https://bugs.gentoo.org/689988
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
dev-haskell/editline/editline-0.2.1.1-r1.ebuild [new file with mode: 0644]
dev-haskell/editline/files/editline-0.2.1.1-tinfo.patch [new file with mode: 0644]

diff --git a/dev-haskell/editline/editline-0.2.1.1-r1.ebuild b/dev-haskell/editline/editline-0.2.1.1-r1.ebuild
new file mode 100644 (file)
index 0000000..d235b45
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit autotools eutils haskell-cabal
+
+DESCRIPTION="Bindings to the editline library (libedit)"
+HOMEPAGE="http://code.haskell.org/editline"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.10.4:=
+       dev-libs/libedit"
+DEPEND="${RDEPEND}
+       >=dev-haskell/cabal-1.2"
+
+PATCHES=(
+       "${FILESDIR}"/${P}-ghc-7.8.patch
+       "${FILESDIR}"/${P}-tinfo.patch
+)
+
+src_prepare() {
+       default
+       eautoconf
+
+       cabal_chdeps \
+               'base < 4.7' 'base'
+}
diff --git a/dev-haskell/editline/files/editline-0.2.1.1-tinfo.patch b/dev-haskell/editline/files/editline-0.2.1.1-tinfo.patch
new file mode 100644 (file)
index 0000000..2f073b6
--- /dev/null
@@ -0,0 +1,13 @@
+https://bugs.gentoo.org/689988
+--- a/configure.ac
++++ b/configure.ac
+@@ -31,7 +31,8 @@ dnl does it.
+ AC_CHECK_LIB(curses, tgetent, HaveLibTermcap=YES; LibTermcap=curses,
+   [AC_CHECK_LIB(ncurses, tgetent, HaveLibTermcap=YES; LibTermcap=ncurses,
+     [AC_CHECK_LIB(termcap, tgetent, HaveLibTermcap=YES; LibTermcap=termcap,
+-      HaveLibTermcap=NO; LibTermcap=not-installed)])])
++      [AC_CHECK_LIB(tinfo, tgetent, HaveLibTermcap=YES; LibTermcap=tinfo,
++        HaveLibTermcap=NO; LibTermcap=not-installed)])])])
+ if test "x$HaveLibTermcap" = xYES ; then
+   HaveLibEdit=YES