dev-ruby/pastel: initial import of 0.7.2
authorHans de Graaff <graaff@gentoo.org>
Sat, 15 Jun 2019 05:26:35 +0000 (07:26 +0200)
committerHans de Graaff <graaff@gentoo.org>
Sat, 15 Jun 2019 09:55:35 +0000 (11:55 +0200)
Dependency for forthcoming dev-ruby/tty-command

Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Package-Manager: Portage-2.3.66, Repoman-2.3.11

dev-ruby/pastel/Manifest [new file with mode: 0644]
dev-ruby/pastel/metadata.xml [new file with mode: 0644]
dev-ruby/pastel/pastel-0.7.2.ebuild [new file with mode: 0644]

diff --git a/dev-ruby/pastel/Manifest b/dev-ruby/pastel/Manifest
new file mode 100644 (file)
index 0000000..4140a8b
--- /dev/null
@@ -0,0 +1 @@
+DIST pastel-0.7.2.gem 49152 BLAKE2B 37380dd9f44f2e816628bda1ed359aeaa961c9b1c18a0e76b4b04fea39906e53601aba17fd2c1cd0571357697296ee1afce3a52fbdc33475a1560c3c2f52e567 SHA512 83cf7ef04800a77ee91692de5b89c6bfe6590be72f24dda74ee53809b14b7e2e9c6e70e9a829eff7aa8dd02a191057dc5f5c5528d36fe2bfd211e1c499d276f0
diff --git a/dev-ruby/pastel/metadata.xml b/dev-ruby/pastel/metadata.xml
new file mode 100644 (file)
index 0000000..5cb98c9
--- /dev/null
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="project">
+               <email>ruby@gentoo.org</email>
+               <name>Gentoo Ruby Project</name>
+       </maintainer>
+       <upstream>
+               <remote-id type="github">piotrmurach/pastel</remote-id>
+       </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/pastel/pastel-0.7.2.ebuild b/dev-ruby/pastel/pastel-0.7.2.ebuild
new file mode 100644 (file)
index 0000000..f71fd3e
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Terminal strings styling with intuitive and clean API"
+HOMEPAGE="https://github.com/piotrmurach/pastel"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+       =dev-ruby/equatable-0.5*
+       =dev-ruby/tty-color-0.5*
+"
+
+all_ruby_prepare() {
+       echo '-rspec_helper' > .rspec || die
+}