app-admin/ulogd: remove old
authorIlya Tumaykin <itumaykin@gmail.com>
Thu, 4 Oct 2018 19:32:45 +0000 (22:32 +0300)
committerAndreas Sturmlechner <asturm@gentoo.org>
Fri, 5 Oct 2018 21:39:29 +0000 (23:39 +0200)
Signed-off-by: Ilya Tumaykin <itumaykin@gmail.com>
Package-Manager: Portage-2.3.50, Repoman-2.3.11
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
app-admin/ulogd/ulogd-2.0.7.ebuild [deleted file]

diff --git a/app-admin/ulogd/ulogd-2.0.7.ebuild b/app-admin/ulogd/ulogd-2.0.7.ebuild
deleted file mode 100644 (file)
index a95d673..0000000
+++ /dev/null
@@ -1,137 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit flag-o-matic linux-info ltprune readme.gentoo-r1 systemd user
-
-DESCRIPTION="A userspace logging daemon for netfilter/iptables related logging"
-HOMEPAGE="https://netfilter.org/projects/ulogd/index.html"
-SRC_URI="https://www.netfilter.org/projects/ulogd/files/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~ia64 ppc x86"
-IUSE="dbi doc json mysql nfacct +nfct +nflog pcap postgres selinux sqlite ulog"
-
-COMMON_DEPEND="
-       || ( net-firewall/iptables net-firewall/nftables )
-       >=net-libs/libnfnetlink-1.0.1
-       dbi? ( dev-db/libdbi )
-       json? ( dev-libs/jansson )
-       nfacct? (
-               >=net-libs/libmnl-1.0.3
-               >=net-libs/libnetfilter_acct-1.0.1
-       )
-       nfct? ( >=net-libs/libnetfilter_conntrack-1.0.2 )
-       nflog? ( >=net-libs/libnetfilter_log-1.0.0 )
-       mysql? ( virtual/mysql )
-       pcap? ( net-libs/libpcap )
-       postgres? ( dev-db/postgresql:= )
-       sqlite? ( dev-db/sqlite:3 )
-"
-DEPEND="${COMMON_DEPEND}
-       doc? (
-               app-text/linuxdoc-tools
-               app-text/texlive-core
-               dev-texlive/texlive-fontsrecommended
-               virtual/latex-base
-       )
-"
-RDEPEND="${COMMON_DEPEND}
-       selinux? ( sec-policy/selinux-ulogd )
-"
-
-DISABLE_AUTOFORMATTING=1
-DOC_CONTENTS="
-You must have at least one logging stack enabled to make ulogd work.
-Please edit the example configuration located at '${EPREFIX}/etc/ulogd.conf'.
-"
-
-pkg_setup() {
-       linux-info_pkg_setup
-
-       if use nfacct && kernel_is lt 3 3 0; then
-               ewarn "NFACCT input plugin requires a kernel >= 3.3."
-       fi
-
-       if use ulog && kernel_is ge 3 17 0; then
-               ewarn "ULOG target has been removed in the 3.17 kernel release."
-               ewarn "Consider enabling NFACCT, NFCT, or NFLOG support instead."
-       fi
-
-       enewgroup ulogd
-       enewuser ulogd -1 -1 /var/log/ulogd ulogd
-}
-
-src_prepare() {
-       default_src_prepare
-
-       # Change default settings to:
-       # - keep log files in /var/log/ulogd instead of /var/log;
-       # - create sockets in /run instead of /tmp.
-       sed -i \
-               -e "s|var/log|var/log/${PN}|g" \
-               -e 's|tmp|run|g' \
-               ulogd.conf.in || die
-}
-
-src_configure() {
-       append-lfs-flags
-       local myeconfargs=(
-               $(use_with dbi)
-               $(use_with json jansson)
-               $(use_enable nfacct)
-               $(use_enable nfct)
-               $(use_enable nflog)
-               $(use_with mysql)
-               $(use_with pcap)
-               $(use_with postgres pgsql)
-               $(use_with sqlite)
-               $(use_enable ulog)
-       )
-       econf "${myeconfargs[@]}"
-}
-
-src_compile() {
-       default_src_compile
-
-       if use doc; then
-               # Prevent access violations from bitmap font files generation.
-               export VARTEXFONTS="${T}/fonts"
-               emake -C doc
-       fi
-}
-
-src_install() {
-       use doc && HTML_DOCS=( doc/${PN}.html )
-
-       default_src_install
-       prune_libtool_files --modules
-       readme.gentoo_create_doc
-
-       doman ${PN}.8
-
-       use doc && dodoc doc/${PN}.{dvi,ps,txt}
-       use mysql && dodoc doc/mysql-*.sql
-       use postgres && dodoc doc/pgsql-*.sql
-       use sqlite && dodoc doc/sqlite3.table
-
-       insinto /etc
-       doins ${PN}.conf
-       fowners root:ulogd /etc/${PN}.conf
-       fperms 640 /etc/${PN}.conf
-
-       newinitd "${FILESDIR}/${PN}.init" ${PN}
-       systemd_dounit "${FILESDIR}/${PN}.service"
-
-       insinto /etc/logrotate.d
-       newins "${FILESDIR}/${PN}.logrotate" ${PN}
-
-       diropts -o ulogd -g ulogd
-       keepdir /var/log/ulogd
-}
-
-pkg_postinst() {
-       readme.gentoo_print_elog
-}