dev-lua/lgi: add slot operator against libffi, bug #688886
authorSergei Trofimovich <slyfox@gentoo.org>
Thu, 19 Sep 2019 07:40:29 +0000 (08:40 +0100)
committerSergei Trofimovich <slyfox@gentoo.org>
Thu, 19 Sep 2019 07:40:29 +0000 (08:40 +0100)
While at it bump up to EAPI=7

Reported-by: Kent Fredric
Closes: https://bugs.gentoo.org/688886
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
dev-lua/lgi/lgi-0.9.0-r1.ebuild [new file with mode: 0644]

diff --git a/dev-lua/lgi/lgi-0.9.0-r1.ebuild b/dev-lua/lgi/lgi-0.9.0-r1.ebuild
new file mode 100644 (file)
index 0000000..e6445f8
--- /dev/null
@@ -0,0 +1,55 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+VIRTUALX_REQUIRED="manual"
+
+inherit eutils toolchain-funcs flag-o-matic virtualx
+
+DESCRIPTION="Lua bindings using gobject-introspection"
+HOMEPAGE="https://github.com/pavouk/lgi"
+SRC_URI="https://github.com/pavouk/lgi/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="examples test"
+
+RDEPEND=">=dev-lang/lua-5.1
+               dev-libs/gobject-introspection
+               dev-libs/glib
+               virtual/libffi:0="
+DEPEND="${RDEPEND}
+               virtual/pkgconfig
+               test? (
+                       x11-libs/cairo[glib]
+                       x11-libs/gtk+[introspection]
+                       ${VIRTUALX_DEPEND}
+               )"
+
+src_prepare() {
+       default
+
+       sed -i \
+               -e "s:^LUA_LIBDIR.*$:LUA_LIBDIR = $($(tc-getPKG_CONFIG) --variable INSTALL_CMOD lua):" \
+               -e "s:^LUA_SHAREDIR.*$:LUA_SHAREDIR = $($(tc-getPKG_CONFIG) --variable INSTALL_LMOD lua):" \
+               "${S}"/lgi/Makefile || die "sed failed"
+}
+
+src_compile() {
+       emake CC="$(tc-getCC)" COPTFLAGS="-Wall -Wextra ${CFLAGS}" LIBFLAG="-shared ${LDFLAGS}"
+}
+
+src_test() {
+       virtx emake CC="$(tc-getCC)" COPTFLAGS="-Wall -Wextra ${CFLAGS}" LIBFLAG="-shared ${LDFLAGS}" check
+}
+
+src_install() {
+       emake DESTDIR="${D}" install
+       dohtml -r docs/*
+       dodoc README.md
+       if use examples; then
+               dodoc -r samples
+       fi
+}