projects
/
gentoo.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
b0c49ba
)
dev-python/pycurl: Rebuild test libs for current platform
author
Michał Górny
<mgorny@gentoo.org>
Mon, 4 May 2020 08:13:24 +0000
(10:13 +0200)
committer
Michał Górny
<mgorny@gentoo.org>
Mon, 4 May 2020 08:34:36 +0000
(10:34 +0200)
Bug: https://bugs.gentoo.org/720906
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pycurl/pycurl-7.43.0.5.ebuild
patch
|
blob
|
history
diff --git
a/dev-python/pycurl/pycurl-7.43.0.5.ebuild
b/dev-python/pycurl/pycurl-7.43.0.5.ebuild
index 83c00755199479a813a99f4c0882d8b972f0f175..4bfe4dc05192e62723825cd21b9ec110faaef7f8 100644
(file)
--- a/
dev-python/pycurl/pycurl-7.43.0.5.ebuild
+++ b/
dev-python/pycurl/pycurl-7.43.0.5.ebuild
@@
-59,6
+59,14
@@
python_configure_all() {
export PYCURL_SSL_LIBRARY=${CURL_SSL/libressl/openssl}
}
+src_test() {
+ # upstream bundles precompiled amd64 libs
+ rm tests/fake-curl/libcurl/*.so || die
+ emake -C tests/fake-curl/libcurl
+
+ distutils-r1_src_test
+}
+
python_compile() {
python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
distutils-r1_python_compile