dev-python/bz2file: Set DISTUTILS_USE_SETUPTOOLS, EAPI 7
authorMichał Górny <mgorny@gentoo.org>
Mon, 16 Dec 2019 13:56:20 +0000 (14:56 +0100)
committerMichał Górny <mgorny@gentoo.org>
Mon, 16 Dec 2019 14:37:30 +0000 (15:37 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/bz2file/bz2file-0.98.ebuild

index 3b741c619575c6b4d308456930d431a54b2cf134..b4c5026de8476f4a0d4de200224a16f091ebde9d 100644 (file)
@@ -1,9 +1,11 @@
 # Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
+DISTUTILS_USE_SETUPTOOLS=no
 PYTHON_COMPAT=( python2_7 pypy )
+
 inherit distutils-r1
 
 DESCRIPTION="Replacement for bz2.BZ2File with features from newest CPython"
@@ -16,5 +18,5 @@ KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sparc x86 ~x64-cy
 IUSE=""
 
 python_test() {
-       "${PYTHON}" test_bz2file.py -v || die "Tests fail with ${EPYTHON}"
+       "${EPYTHON}" test_bz2file.py -v || die "Tests fail with ${EPYTHON}"
 }