dev-python/setuptools: Silence py2 warning
authorMichał Górny <mgorny@gentoo.org>
Mon, 18 May 2020 13:04:33 +0000 (15:04 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 18 May 2020 13:23:14 +0000 (15:23 +0200)
The py2 warning is not very useful for us and its verbosity breaks
other packages.

Closes: https://bugs.gentoo.org/723680
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/setuptools/setuptools-46.4.0-r1.ebuild [moved from dev-python/setuptools/setuptools-46.4.0.ebuild with 91% similarity]

similarity index 91%
rename from dev-python/setuptools/setuptools-46.4.0.ebuild
rename to dev-python/setuptools/setuptools-46.4.0-r1.ebuild
index 12991147d66555c389ec897abb328188eb40cb85..fff9aec03927f9cf3075047794f9816710dadf4d 100644 (file)
@@ -41,6 +41,11 @@ DISTUTILS_IN_SOURCE_BUILD=1
 DOCS=( {CHANGES,README}.rst docs/{easy_install.txt,pkg_resources.txt,setuptools.txt} )
 
 python_prepare_all() {
+       # silence the py2 warning that is awfully verbose and breaks some
+       # packages by adding unexpected output
+       # (also, we know!)
+       sed -i -e '/py2_warn/d' pkg_resources/__init__.py || die
+
        # disable tests requiring a network connection
        rm setuptools/tests/test_packageindex.py || die