dev-python/isort: Replace virts with cond deps
authorMichał Górny <mgorny@gentoo.org>
Mon, 16 Mar 2020 21:03:13 +0000 (22:03 +0100)
committerMichał Górny <mgorny@gentoo.org>
Mon, 16 Mar 2020 21:09:37 +0000 (22:09 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/isort/isort-4.3.21_p2.ebuild

index e25a7d403960c66f953fe95d188d6db0aa296d5e..17e14eefd37dc868593cb62d89f333cfc3cb3f95 100644 (file)
@@ -20,8 +20,10 @@ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~sparc ~x86"
 RDEPEND="
        dev-python/setuptools[${PYTHON_USEDEP}]
        dev-python/pipfile[${PYTHON_USEDEP}]
-       virtual/python-futures[${PYTHON_USEDEP}]
-       $(python_gen_cond_dep 'dev-python/backports-functools-lru-cache[${PYTHON_USEDEP}]' -2)
+       $(python_gen_cond_dep '
+               dev-python/backports-functools-lru-cache[${PYTHON_USEDEP}]
+               dev-python/futures[${PYTHON_USEDEP}]
+       ' -2)
 "
 BDEPEND="${RDEPEND}"