app-crypt/ccid: Version bump (v1.4.31)
authorMikle Kolyada <zlogene@gentoo.org>
Sun, 10 Nov 2019 12:41:48 +0000 (15:41 +0300)
committerMikle Kolyada <zlogene@gentoo.org>
Sun, 10 Nov 2019 12:42:21 +0000 (15:42 +0300)
Package-Manager: Portage-2.3.76, Repoman-2.3.16
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
app-crypt/ccid/Manifest
app-crypt/ccid/ccid-1.4.31.ebuild [new file with mode: 0644]

index e8ad3dcb3726efe5a91c6ba150c2749b908ca29b..a38e1b1535d3b79c33789c8d469531c3efbf0831 100644 (file)
@@ -1 +1,2 @@
 DIST ccid-1.4.30.tar.bz2 642342 BLAKE2B fd43aa2a4c8840abb0545760f6ceb31bb9d7dc22d7283888c9a142e0c3b34310ec4530d18986451b21c6b1a3975b1212ab653a4c8d58466b28713f0f72ce1cdb SHA512 1761a4053a99eb28184d0ffece951aec5d4b646080597b4ae36b18a31fb7a76c55fabfa57ee8e5d7f2db1a6e13d209f7fa995fe6ed067f44558bea34a26d46da
+DIST ccid-1.4.31.tar.bz2 644039 BLAKE2B bd8e9c69e122348ffbeddc4f85f939d7d4c93dbfe5f712bc16f671af144570ce2c3bc6da04503851f4ce0f95f0c89bbbe6bbf0852be97cf5574993875d865870 SHA512 51d102c6be5b234ed568522d51b97bdb27c4c22d9610874abd7a18314f4e8ebe81fcb18a16a1edbdc814ee652a037d50202673a50de2fdeb0eac74063b149ed3
diff --git a/app-crypt/ccid/ccid-1.4.31.ebuild b/app-crypt/ccid/ccid-1.4.31.ebuild
new file mode 100644 (file)
index 0000000..12813fa
--- /dev/null
@@ -0,0 +1,61 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs udev
+
+DESCRIPTION="CCID free software driver"
+HOMEPAGE="https://ccid.apdu.fr/"
+SRC_URI="https://ccid.apdu.fr/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="twinserial kobil-midentity +usb"
+
+RDEPEND=">=sys-apps/pcsc-lite-1.8.3
+       usb? ( virtual/libusb:1 )"
+DEPEND="${RDEPEND}"
+BDEPEND="kernel_linux? ( virtual/pkgconfig )"
+
+DOCS=( README.md AUTHORS )
+
+src_configure() {
+       econf \
+               LEX=: \
+               $(use_enable twinserial) \
+               $(use_enable usb libusb)
+}
+
+src_compile() {
+       default
+       use kobil-midentity && emake -C contrib/Kobil_mIDentity_switch
+}
+
+src_install() {
+       default
+
+       if use kobil-midentity; then
+               dosbin contrib/Kobil_mIDentity_switch/Kobil_mIDentity_switch
+               doman contrib/Kobil_mIDentity_switch/Kobil_mIDentity_switch.8
+       fi
+
+       if use kernel_linux; then
+               # note: for eudev support, rules probably will always need to be
+               # installed to /usr
+
+               # ccid >=1.4.11 version changed the rules drastically in a minor
+               # release to no longer use the pcscd group. Using the old ones in
+               # the mean time.
+               udev_newrules "${FILESDIR}"/92_pcscd_ccid-2.rules 92-pcsc-ccid.rules
+
+               # disable Kobil_mIDentity_switch udev rule with USE=-kobil-midentity
+               if ! use kobil-midentity; then
+                       sed \
+                               -e '/Kobil_mIDentity_switch/s/^/#/' \
+                               -i "${D}/$(get_udevdir)"/rules.d/92-pcsc-ccid.rules || die
+               fi
+
+       fi
+}