dev-python/bottle: Replace python_gen_usedep
authorMichał Górny <mgorny@gentoo.org>
Mon, 16 Dec 2019 14:02:41 +0000 (15:02 +0100)
committerMichał Górny <mgorny@gentoo.org>
Mon, 16 Dec 2019 14:37:38 +0000 (15:37 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/bottle/bottle-0.12.16.ebuild

index 529b10e1111ea86049899defb8600ea070ea93f8..4d5b75adc20f4f4a289c617acf6bb4aab0b07d30 100644 (file)
@@ -18,7 +18,11 @@ IUSE="test"
 RESTRICT="!test? ( test )"
 
 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
-       test? ( dev-python/mako[$(python_gen_usedep 'python*')] )"
+       test? (
+               $(python_gen_cond_dep '
+                       dev-python/mako[${PYTHON_USEDEP}]
+               ' 'python*')
+       )"
 RDEPEND=""
 
 PATCHES=(
@@ -36,7 +40,7 @@ python_prepare_all() {
 python_test() {
        # A few odd fails in the suite under pypy
        # https://github.com/bottlepy/bottle/issues/714
-       "${PYTHON}" test/testall.py || die "tests failed under ${EPYTHON}"
+       "${EPYTHON}" test/testall.py || die "tests failed under ${EPYTHON}"
 }
 
 pkg_postinst() {