dev-python/pytest-virtualenv: Set DISTUTILS_USE_SETUPTOOLS
authorMichał Górny <mgorny@gentoo.org>
Mon, 16 Dec 2019 14:24:15 +0000 (15:24 +0100)
committerMichał Górny <mgorny@gentoo.org>
Mon, 16 Dec 2019 14:37:57 +0000 (15:37 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pytest-virtualenv/pytest-virtualenv-1.7.0.ebuild

index 0f53a35b999e39851b1062ab4c23b0d1e800c04b..ce2151787c0a89e741f19b821611388d682941cc 100644 (file)
@@ -2,6 +2,8 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
 PYTHON_COMPAT=( python{2_7,3_{5,6,7}} pypy{,3} )
 
 inherit distutils-r1
@@ -13,22 +15,17 @@ SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
 LICENSE="MIT"
 SLOT="0"
 KEYWORDS="~amd64 ~hppa ~mips ~s390 ~sparc ~x86"
-IUSE="test"
 
 RDEPEND="
        dev-python/pytest-fixture-config[${PYTHON_USEDEP}]
        dev-python/pytest-shutil[${PYTHON_USEDEP}]
        dev-python/pytest[${PYTHON_USEDEP}]
-       dev-python/setuptools[${PYTHON_USEDEP}]
        dev-python/virtualenv[${PYTHON_USEDEP}]
 "
 BDEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
        test? (
-               ${RDEPEND}
                dev-python/mock[${PYTHON_USEDEP}]
        )
 "
-RESTRICT="!test? ( test )"
 
 distutils_enable_tests setup.py