Bump to 0.13.1
authorAlexandre Buisse <nattfodd@gentoo.org>
Fri, 1 Dec 2006 18:35:17 +0000 (18:35 +0000)
committerAlexandre Buisse <nattfodd@gentoo.org>
Fri, 1 Dec 2006 18:35:17 +0000 (18:35 +0000)
Package-Manager: portage-2.1.2_rc2-r2

media-sound/lltag/ChangeLog
media-sound/lltag/files/digest-lltag-0.13.1 [new file with mode: 0644]
media-sound/lltag/lltag-0.13.1.ebuild [new file with mode: 0644]

index 6e208ddbf61a2717b6db3c72011bb89040f87dfe..1eb19beddb7dc02fb6f83806e640831a786d45fa 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for media-sound/lltag
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lltag/ChangeLog,v 1.10 2006/11/16 22:41:37 nattfodd Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lltag/ChangeLog,v 1.11 2006/12/01 18:35:16 nattfodd Exp $
+
+*lltag-0.13.1 (01 Dec 2006)
+
+  01 Dec 2006; Alexandre Buisse <nattfodd@gentoo.org> -lltag-0.13.ebuild,
+  +lltag-0.13.1.ebuild:
+  Bump to 0.13.1
 
 *lltag-0.13 (16 Nov 2006)
 
diff --git a/media-sound/lltag/files/digest-lltag-0.13.1 b/media-sound/lltag/files/digest-lltag-0.13.1
new file mode 100644 (file)
index 0000000..45516e0
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 231e80e9c400d01843641ef3a4975386 lltag-0.13.1.tar.bz2 40313
+RMD160 68169d1eef71fb596f845fff1530ea28b66e2554 lltag-0.13.1.tar.bz2 40313
+SHA256 36026342161e5db0f6d8fc7d8a0eaeec56ac3d5ab1aa7a01030805c3bd6cf2e0 lltag-0.13.1.tar.bz2 40313
diff --git a/media-sound/lltag/lltag-0.13.1.ebuild b/media-sound/lltag/lltag-0.13.1.ebuild
new file mode 100644 (file)
index 0000000..a484ced
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lltag/lltag-0.13.1.ebuild,v 1.1 2006/12/01 18:35:16 nattfodd Exp $
+
+inherit perl-module
+
+DESCRIPTION="Automatic command-line mp3/ogg/flac file tagger and renamer"
+HOMEPAGE="http://home.gna.org/lltag"
+SRC_URI="http://download.gna.org/lltag/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="mp3 ogg flac readline"
+
+RDEPEND="dev-lang/perl
+       dev-perl/libwww-perl
+       mp3? ( media-sound/mp3info )
+       ogg? ( media-sound/vorbis-tools )
+       flac? ( media-libs/flac )
+       readline? ( dev-perl/Term-ReadLine-Perl )"
+
+src_compile() {
+       make PREFIX=/usr SYSCONFDIR=/etc MANDIR=/usr/share/man \
+       PERL_INSTALLDIRS=vendor || die "Failed to compile"
+}
+
+src_install() {
+       make DESTDIR="${D}/" PREFIX=/usr SYSCONFDIR=/etc MANDIR=/usr/share/man \
+       PERL_INSTALLDIRS=vendor DOCDIR=/usr/share/doc/${P} install \
+       install-doc install-man || die "Failed to install"
+       fixlocalpod
+       dodoc Changes
+}