projects
/
gentoolkit.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
69be3fc
)
Fixed svn mv/cp detection.
author
idl0r
<idl0r@gentoo.org>
Wed, 29 Apr 2009 10:54:15 +0000
(10:54 -0000)
committer
idl0r
<idl0r@gentoo.org>
Wed, 29 Apr 2009 10:54:15 +0000
(10:54 -0000)
svn path=/; revision=553
trunk/src/echangelog/echangelog
patch
|
blob
|
history
diff --git
a/trunk/src/echangelog/echangelog
b/trunk/src/echangelog/echangelog
index 28358fa12de6a969ddd611261a32444961fc91ea..347adbeafcfade4eac4f9f54dd4ff3edcd451f21 100755
(executable)
--- a/
trunk/src/echangelog/echangelog
+++ b/
trunk/src/echangelog/echangelog
@@
-387,7
+387,7
@@
if (($vcs eq "svn") and (@ebuilds)) {
$_ = <C>;
while (defined $_) {
- if (/^A\s*(([^\s]*)\.ebuild)/) {
+ if (/^A\s
+\+?\s
*(([^\s]*)\.ebuild)/) {
mypush(@files, $1);
mypush(@new_versions, $2);
}