sci-libs/colamd: new version 2.9.6.
authorMichael Orlitzky <mjo@gentoo.org>
Sat, 29 Feb 2020 01:50:46 +0000 (20:50 -0500)
committerMichael Orlitzky <mjo@gentoo.org>
Mon, 2 Mar 2020 17:20:43 +0000 (12:20 -0500)
Update to EAPI=7 and fix the HOMEPAGE, SRC_URI, and LICENSE. This is
part of a larger SuiteSparse v5.4.0 upgrade thanks to François Bissey
whose sage-on-gentoo ebuilds I'm using. There's a newer release
(v5.7.1) of SuiteSparse, but v5.4.0 has seen more testing.

Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
sci-libs/colamd/Manifest
sci-libs/colamd/colamd-2.9.6.ebuild [new file with mode: 0644]

index b14ad09ad0887dc2a992b8ecf5d8d24941f1c34d..daefba89b3754d323aa18c48445ccab49c1fd303 100644 (file)
@@ -1 +1,2 @@
 DIST colamd-2.8.0.tar.bz2 304819 BLAKE2B a2c4b67ad8d20b0cb136f579a367bf53b0e692596550b9e22908628f4d0bce00e2ddeb9aa0dfe6d1f204e79332be99c97366df2ba555ab881d4ba01c42a721e6 SHA512 36b2e50e01ad44f04f084ebcdcfb7d9d1d1712c6f53c8bce9f46ce39edc418aa64b8e67489fb06cb95d86658fd9f9bad89217a5f9f4777181f0f0e9b58c04aee
+DIST colamd-2.9.6.tar.bz2 298903 BLAKE2B e1e3cfa0153e21b742854d28fb6d3ede287c2ec22cfef4268a8aba8bb239be527433907f6984dad976341cf6e1ca9cb39f5c97029ad9bed032a874add9aa0e02 SHA512 f302d18f9ba004c9d1b0e1ada76e70f20fa1d11896815e5300983513b7ed4a7b969adef33adb1a57d67ce856a5ded410874c23d9bba42b6bf1a6a790430f5137
diff --git a/sci-libs/colamd/colamd-2.9.6.ebuild b/sci-libs/colamd/colamd-2.9.6.ebuild
new file mode 100644 (file)
index 0000000..2ddcb5d
--- /dev/null
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Column approximate minimum degree ordering algorithm"
+HOMEPAGE="http://faculty.cse.tamu.edu/davis/suitesparse.html"
+SRC_URI="http://202.36.178.9/sage/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="static-libs"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND=">=sci-libs/suitesparseconfig-5.4.0"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+       econf $(use_enable static-libs static)
+}