dev-python/netaddr: Restrict cli to py3
authorMichał Górny <mgorny@gentoo.org>
Tue, 3 Dec 2019 09:55:03 +0000 (10:55 +0100)
committerMichał Górny <mgorny@gentoo.org>
Wed, 4 Dec 2019 17:13:30 +0000 (18:13 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/netaddr/netaddr-0.7.19.ebuild

index 743a00abf0a0d81ec0ea4169509e5a5cf1a0d8e3..33dd2ae10c0ff9bdd8fcfbd37f546d0e82939a0c 100644 (file)
@@ -15,8 +15,14 @@ LICENSE="BSD"
 SLOT="0"
 KEYWORDS="amd64 ~arm ~arm64 x86 ~amd64-linux ~x86-linux"
 IUSE="cli test"
+REQUIRED_USE="cli? ( || ( $(python_gen_useflags -3) ) )"
 
-RDEPEND="cli? ( >=dev-python/ipython-0.13.1-r1[${PYTHON_USEDEP}] )"
+RDEPEND="
+       cli? (
+               $(python_gen_cond_dep '
+                       >=dev-python/ipython-0.13.1-r1[${PYTHON_USEDEP}]
+               ' -3)
+       )"
 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
        test? (
                dev-python/pytest[${PYTHON_USEDEP}]