dev-python/aniso8601: Bump to 8.0.0, py3.8
authorMichał Górny <mgorny@gentoo.org>
Fri, 17 Apr 2020 10:11:09 +0000 (12:11 +0200)
committerMichał Górny <mgorny@gentoo.org>
Fri, 17 Apr 2020 10:11:09 +0000 (12:11 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/aniso8601/Manifest
dev-python/aniso8601/aniso8601-8.0.0.ebuild [new file with mode: 0644]

index 16d45a99465fa265ca2726dc21bcef16ffc8976f..53c0271517bdd2afc1f7435ebcd80337aae0739f 100644 (file)
@@ -1 +1,2 @@
 DIST aniso8601-4.0.1.tar.gz 109849 BLAKE2B 487bf340e181997219c2e39ed887161c3f5daa336cee79ce947b55a11c463b439086c3985fc93184de550f5e34e03f2d855ccb9a3072c0dc16ac21bf02a7e78f SHA512 5638ebf82a1a1aceee866eb17e8e4b5c8023961a9e31ce3e12123b89dba0ea0924e10a6aa458c838fcfdb72b94af4e81b3e9e8805cb534a1eccaf5a51f2026c9
+DIST aniso8601-8.0.0.tar.gz 37007 BLAKE2B bb5f42928308fab7746cbea364c03db4813b1b25883495d0488eb755e14f465300662b07c4ccfd03328a0c0f07ed87056ccc13f2652648c4838b0433740fc3ab SHA512 1e6c43f77993e829833d819f7c2b9b1d31f30ca46e258faac0e0b3be864da07436ae34f05710309302477bb3eede5966c95ef3b124c9b353b306c2272dc4cb9d
diff --git a/dev-python/aniso8601/aniso8601-8.0.0.ebuild b/dev-python/aniso8601/aniso8601-8.0.0.ebuild
new file mode 100644 (file)
index 0000000..118b9c5
--- /dev/null
@@ -0,0 +1,19 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A library for parsing ISO 8601 strings"
+HOMEPAGE="https://bitbucket.org/nielsenb/aniso8601/ https://pypi.org/project/aniso8601/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND=">=dev-python/python-dateutil-2.7.3[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest