dev-python/doublex: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Fri, 27 Mar 2020 07:07:51 +0000 (08:07 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 27 Mar 2020 07:25:28 +0000 (08:25 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/doublex/Manifest
dev-python/doublex/doublex-1.8.1.ebuild [deleted file]

index 61bc4b3c91570296d0abf5c12fb72f81269cac0c..808466437d18f463a2c4eaf0ab8d6f9eae648ce2 100644 (file)
@@ -1,2 +1 @@
-DIST doublex-1.8.1.tar.gz 69685 BLAKE2B 38f80ac0cf68dc2401eaa8051542c91d382e9ba22ed229b3c12a192f0b180b33a5660e54f647b2273401500a3292619d918dde9b0f685807217bca40e1aafbfc SHA512 30d2b572862370da8402cc2cfa5481d3278f0fefd2d5b2f5be126a793c8e165df0e2ae6089ba321e71d994f14024b882933c1523f7a0b9e341bf75644b49e073
 DIST doublex-1.9.2.tar.gz 80246 BLAKE2B 7fc1c4e6d117bee13e7125b634293aa7c9d1016c9cd5201f047143bcb1fae1e9607bf0a030cbaa2d6eb930474babe29aaf244433aba57ae4325a3a43af2fdf56 SHA512 0278f756930b0d5c3da676e3908ccc17b919c14f740aace3002f5117fa341ac52fe16fdaa2c3b36029757dd1dc2f36d8d35cdc8664fcfdbcafd4809d2fc969b0
diff --git a/dev-python/doublex/doublex-1.8.1.ebuild b/dev-python/doublex/doublex-1.8.1.ebuild
deleted file mode 100644 (file)
index 95e4680..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1 vcs-snapshot
-
-DESCRIPTION="Python test doubles"
-HOMEPAGE="https://bitbucket.org/DavidVilla/python-doublex"
-SRC_URI="https://bitbucket.org/DavidVilla/python-${PN}/get/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-CDEPEND="dev-python/pyhamcrest[${PYTHON_USEDEP}]"
-DEPEND="
-       ${CDEPEND}
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-       test? (
-               dev-python/nose[${PYTHON_USEDEP}]
-       )
-"
-RDEPEND="${CDEPEND}"
-
-python_compile_all() {
-       use doc && emake -C docs
-}
-
-python_test() {
-       esetup.py test
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( docs/_build/html/. )
-
-       distutils-r1_python_install_all
-
-       rm "${ED}"/usr/README.rst || die "Couldn't remove spurious README.rst"
-}