x11-libs/pixman: Limit test suite $(makeopts_jobs) threads
authorMatt Turner <mattst88@gentoo.org>
Tue, 9 Jul 2019 20:16:41 +0000 (13:16 -0700)
committerMatt Turner <mattst88@gentoo.org>
Sat, 13 Jul 2019 17:37:04 +0000 (10:37 -0700)
Otherwise we would run as many OpenMP threads as there are CPU cores and
ignore MAKEOPTS. Since we're running tests in parallel *and* the tests
spawn multiple threads, we will still exceed $(makeopts_jobs) threads
total, but I don't think that can be helped.

Closes: https://bugs.gentoo.org/688926
Signed-off-by: Matt Turner <mattst88@gentoo.org>
x11-libs/pixman/pixman-0.38.4.ebuild
x11-libs/pixman/pixman-9999.ebuild

index b5fcceac9572ae2165f69930a52ca5c7f6aa3345..91bb30113a62c40aeaad75a57fec3703daadb2dc 100644 (file)
@@ -9,7 +9,7 @@ if [[ ${PV} = 9999* ]]; then
        GIT_ECLASS="git-r3"
 fi
 
-inherit ${GIT_ECLASS} meson multilib-minimal toolchain-funcs
+inherit ${GIT_ECLASS} meson multilib-minimal multiprocessing toolchain-funcs
 
 DESCRIPTION="Low-level pixel manipulation routines"
 HOMEPAGE="http://www.pixman.org/ https://gitlab.freedesktop.org/pixman/pixman/"
@@ -54,6 +54,7 @@ multilib_src_compile() {
 }
 
 multilib_src_test() {
+       export OMP_NUM_THREADS=$(makeopts_jobs)
        meson test -v -C "${BUILD_DIR}" -t 100
 }
 
index 0e6923456a80749bfae8f576b287e618183ad5c1..17ea41af3389bfce81961a27c16c84ab56de0e6a 100644 (file)
@@ -9,7 +9,7 @@ if [[ ${PV} = 9999* ]]; then
        GIT_ECLASS="git-r3"
 fi
 
-inherit ${GIT_ECLASS} meson multilib-minimal toolchain-funcs
+inherit ${GIT_ECLASS} meson multilib-minimal multiprocessing toolchain-funcs
 
 DESCRIPTION="Low-level pixel manipulation routines"
 HOMEPAGE="http://www.pixman.org/ https://gitlab.freedesktop.org/pixman/pixman/"
@@ -54,6 +54,7 @@ multilib_src_compile() {
 }
 
 multilib_src_test() {
+       export OMP_NUM_THREADS=$(makeopts_jobs)
        meson test -v -C "${BUILD_DIR}" -t 100
 }