dev-python/python-saharaclient: 1.5.0
authorMatthew Thode <prometheanfire@gentoo.org>
Sat, 24 Feb 2018 06:52:56 +0000 (00:52 -0600)
committerMatthew Thode <prometheanfire@gentoo.org>
Sat, 24 Feb 2018 06:52:56 +0000 (00:52 -0600)
Package-Manager: Portage-2.3.19, Repoman-2.3.6

dev-python/python-saharaclient/Manifest
dev-python/python-saharaclient/python-saharaclient-0.11.0.ebuild [deleted file]
dev-python/python-saharaclient/python-saharaclient-1.5.0.ebuild [new file with mode: 0644]

index 8ba64255ff8dc2e1c57d55ceb99e206716972c1f..1c31215bf762890ea4823c2acb21632bc662ebc9 100644 (file)
@@ -1,2 +1,2 @@
-DIST python-saharaclient-0.11.0.tar.gz 101842 BLAKE2B 0794f58e8add97161db0d65e282b7efa8c5d772a8c4666ff0a8f36d5a3055d9cf03cbdd34cac70828b56924aae7a64719519fc8d625c748e51430d2f0379dada SHA512 de30918d23b5b8191b2e49f0f7116510533da15be412d87c9018af2e4144082e9cb127713a4aff3ac03d72867a9855d73cbd56b83db24a9bad9b7b422c451018
 DIST python-saharaclient-1.1.0.tar.gz 81664 BLAKE2B 8bfc8ed2bcc4cc13e6894d7776f7cb99c8a72632e132801df689832ef847c56b7cedf39abb112223a2919ea3ef52fc99e31290f7acb555f76505e11f195c48db SHA512 0799549d68bc65792cdf0129f3590667a1a87697182ad24c5c41e9c01abf5e133a16a60fe0331f313da44017aaf0503bbc131e8a62536a692032af36ae9f1386
+DIST python-saharaclient-1.5.0.tar.gz 94824 BLAKE2B cacc3f2e8a1df5f7e50f5b5c004745333ea4b287c0a86792247212fb873ec55329719f16472c3c7fef196f2ce8fd05c760e8db33b84e0ea949f7e89997c0f960 SHA512 8b845ad0eefa05b564659dea9e619a3946e0d62a981b46a4fecfc2d4aab785b8eeb2e18266d5467efd8e0ca31c441af7da41a816ea42405a8cd137adeae2793b
diff --git a/dev-python/python-saharaclient/python-saharaclient-0.11.0.ebuild b/dev-python/python-saharaclient/python-saharaclient-0.11.0.ebuild
deleted file mode 100644 (file)
index 44ad54f..0000000
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="This is a client for the OpenStack Sahara API, aka HADOOP"
-HOMEPAGE="https://github.com/openstack/python-saharaclient"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-CDEPEND="
-       >=dev-python/pbr-1.6.0[${PYTHON_USEDEP}]
-       <dev-python/pbr-2.0[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
-       ${CDEPEND}
-       test? (
-               >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
-               >=dev-python/mock-1.2[${PYTHON_USEDEP}]
-               >=dev-python/oslo-config-2.3.0[${PYTHON_USEDEP}]
-               >=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
-               >=dev-python/python-neutronclient-2.6.0[${PYTHON_USEDEP}]
-               >=dev-python/python-novaclient-2.26.0[${PYTHON_USEDEP}]
-               >=dev-python/python-swiftclient-2.2.0[${PYTHON_USEDEP}]
-               >=dev-python/requests-mock-0.6.0[${PYTHON_USEDEP}]
-               >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
-               !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
-               <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
-               >=dev-python/tempest-lib-0.6.1[${PYTHON_USEDEP}]
-               >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
-       )"
-RDEPEND="
-       ${CDEPEND}
-       >=dev-python/Babel-1.3[${PYTHON_USEDEP}]
-       >=dev-python/cliff-1.14.0[${PYTHON_USEDEP}]
-       >=dev-python/netaddr-0.7.12[${PYTHON_USEDEP}]
-       !~dev-python/netaddr-0.7.16[${PYTHON_USEDEP}]
-       >=dev-python/oslo-i18n-1.5.0[${PYTHON_USEDEP}]
-       >=dev-python/oslo-utils-2.0.0[${PYTHON_USEDEP}]
-       >=dev-python/python-keystoneclient-1.6.0[${PYTHON_USEDEP}]
-       >=dev-python/python-openstackclient-1.5.0[${PYTHON_USEDEP}]
-       >=dev-python/requests-2.5.2[${PYTHON_USEDEP}]
-       >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
-       >=dev-python/prettytable-0.7[${PYTHON_USEDEP}]
-       <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
-       >=dev-python/oslo-log-1.10.0[${PYTHON_USEDEP}]"
-
-python_prepare_all() {
-       sed -i '/^argparse/d' requirements.txt || die
-       sed -i '/^hacking/d' test-requirements.txt || die
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       testr init
-       testr run --parallel || die "testsuite failed under python2.7"
-}
diff --git a/dev-python/python-saharaclient/python-saharaclient-1.5.0.ebuild b/dev-python/python-saharaclient/python-saharaclient-1.5.0.ebuild
new file mode 100644 (file)
index 0000000..2decbd6
--- /dev/null
@@ -0,0 +1,58 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="This is a client for the OpenStack Sahara API, aka HADOOP"
+HOMEPAGE="https://github.com/openstack/python-saharaclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+       !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+       ${CDEPEND}
+       test? (
+               >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+               !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
+               >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+               >=dev-python/openstackdocstheme-1.18.1[${PYTHON_USEDEP}]
+               >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+               >=dev-python/os-testr-1.0.0[${PYTHON_USEDEP}]
+               >=dev-python/reno-2.5.0[${PYTHON_USEDEP}]
+               >=dev-python/requests-mock-1.1.0[${PYTHON_USEDEP}]
+               >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
+               !~dev-python/sphinx-1.6.6[${PYTHON_USEDEP}]
+               >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+       )"
+RDEPEND="
+       ${CDEPEND}
+       >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+       !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+       >=dev-python/keystoneauth-3.3.0[${PYTHON_USEDEP}]
+       >=dev-python/osc-lib-1.8.0[${PYTHON_USEDEP}]
+       >=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
+       >=dev-python/oslo-serialization-1.18.0[${PYTHON_USEDEP}]
+       !~dev-python/oslo-serialization-1.19.1[${PYTHON_USEDEP}]
+       >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+       >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+       >=dev-python/python-openstackclient-3.12.0[${PYTHON_USEDEP}]
+       >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+       >=dev-python/six-1.10.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+       sed -i '/^hacking/d' test-requirements.txt || die
+       distutils-r1_python_prepare_all
+}
+
+python_test() {
+       testr init
+       testr run --parallel || die "testsuite failed under python2.7"
+}