dev-cpp/lucene++: EAPI-6 bump
authorAndreas Sturmlechner <asturm@gentoo.org>
Sun, 14 Oct 2018 13:48:27 +0000 (15:48 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Mon, 22 Oct 2018 16:13:49 +0000 (18:13 +0200)
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Package-Manager: Portage-2.3.51, Repoman-2.3.11
Closes: https://github.com/gentoo/gentoo/pull/10144

dev-cpp/lucene++/lucene++-3.0.7-r1.ebuild [new file with mode: 0644]

diff --git a/dev-cpp/lucene++/lucene++-3.0.7-r1.ebuild b/dev-cpp/lucene++/lucene++-3.0.7-r1.ebuild
new file mode 100644 (file)
index 0000000..731f887
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_P="LucenePlusPlus-rel_${PV}"
+inherit cmake-utils
+
+DESCRIPTION="C++ port of Lucene library, a high-performance, full-featured text search engine"
+HOMEPAGE="https://github.com/luceneplusplus/LucenePlusPlus"
+SRC_URI="https://github.com/luceneplusplus/LucenePlusPlus/archive/rel_${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( LGPL-3 Apache-2.0 )"
+SLOT="0"
+KEYWORDS="amd64 hppa ppc ppc64 sparc x86"
+IUSE="debug"
+
+DEPEND="dev-libs/boost:="
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( AUTHORS README.rst )
+
+PATCHES=( "${FILESDIR}/${P}-boost-1.58.patch" )
+
+src_configure() {
+       local mycmakeargs=(
+               -DENABLE_DEMO=OFF
+               -DENABLE_TEST=OFF
+       )
+
+       cmake-utils_src_configure
+}