dev-python/guessit: Remove 9999
authorMichał Górny <mgorny@gentoo.org>
Sun, 3 May 2020 14:15:00 +0000 (16:15 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 3 May 2020 16:09:22 +0000 (18:09 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/guessit/guessit-9999.ebuild [deleted file]

diff --git a/dev-python/guessit/guessit-9999.ebuild b/dev-python/guessit/guessit-9999.ebuild
deleted file mode 100644 (file)
index 150c824..0000000
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1 git-r3
-
-DESCRIPTION="Python library for guessing information from video filenames"
-HOMEPAGE="https://github.com/guessit-io/guessit https://pypi.org/project/guessit/"
-EGIT_REPO_URI="https://github.com/guessit-io/guessit.git"
-EGIT_BRANCH="develop"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS=""
-
-RDEPEND="
-       >=dev-python/babelfish-0.5.5[${PYTHON_USEDEP}]
-       >=dev-python/rebulk-0.9.0[${PYTHON_USEDEP}]
-       dev-python/python-dateutil[${PYTHON_USEDEP}]
-       dev-python/pyyaml[${PYTHON_USEDEP}]
-       dev-python/six[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
-       # Disable benchmarks as they require unavailable pytest-benchmark.
-       rm guessit/test/test_benchmark.py || die
-       sed -i -e "s|'pytest-benchmark',||g" setup.py || die
-
-       # Disable unconditional dependency on dev-python/pytest-runner.
-       sed -i -e "s|'pytest-runner'||g" setup.py || die
-
-       distutils-r1_python_prepare_all
-}