media-libs/libheif: bump to v1.4.0
authorThomas Deutschmann <whissi@gentoo.org>
Mon, 10 Jun 2019 19:01:14 +0000 (21:01 +0200)
committerThomas Deutschmann <whissi@gentoo.org>
Mon, 10 Jun 2019 19:50:09 +0000 (21:50 +0200)
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
media-libs/libheif/Manifest
media-libs/libheif/libheif-1.4.0.ebuild [new file with mode: 0644]
media-libs/libheif/libheif-9999.ebuild

index 477b5f924659e4f16a1b87e2a380330d33b71896..4cdaac830c933f20324eb5557579af0ec1be5d6c 100644 (file)
@@ -1 +1,2 @@
 DIST libheif-1.3.2.tar.gz 1328174 BLAKE2B 4c0f82bb90d48f89a4ce9aed525c5823bb5d008e54e580e761f6fa4f5493f265929a0607e7b81046ba7c249bd2ca21a0c5ab91da83b7e7f3a2a63e8f24df88ed SHA512 bcc8b4b2522ef6fe68f5a9ffd5312c2c8f6bc3718394eef1860e199c30fb735bb214f665ed6480b5f5fe5d578b3ed77a4301af93775ae2349ba5038b3f3ef63a
+DIST libheif-1.4.0.tar.gz 1366030 BLAKE2B a93b3b59a4f89e0aa5a5069fdebc54b9d09adeeff05ebf28b9535baa2fb26e4122b4c5d96b7015fdd181720f10e3dd0887038f0c5567c94509aa76d2ef119dd9 SHA512 fc48caaadb71ffa87227de75c9e13d5006c66f1c966ce454552defb8947999f5242a9bbd1413f58be1ccbf61df7f118defe96d67376e3b4e7b12fe5dfa0fe0c7
diff --git a/media-libs/libheif/libheif-1.4.0.ebuild b/media-libs/libheif/libheif-1.4.0.ebuild
new file mode 100644 (file)
index 0000000..a03be0a
--- /dev/null
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit autotools multilib-minimal
+
+if [[ ${PV} == "9999" ]] ; then
+       EGIT_REPO_URI="https://github.com/strukturag/${PN}.git"
+       inherit git-r3
+else
+       SRC_URI="https://github.com/strukturag/${PN}/releases/download/v${PV}/${P}.tar.gz"
+       KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="ISO/IEC 23008-12:2017 HEIF file format decoder and encoder"
+HOMEPAGE="https://github.com/strukturag/libheif"
+
+LICENSE="GPL-3"
+SLOT="0/1.4"
+IUSE="static-libs test +threads"
+
+BDEPEND="test? ( dev-lang/go )"
+DEPEND="
+       media-libs/libde265:=[${MULTILIB_USEDEP}]
+       media-libs/libpng:0=[${MULTILIB_USEDEP}]
+       media-libs/x265:=[${MULTILIB_USEDEP}]
+       sys-libs/zlib:=[${MULTILIB_USEDEP}]
+       virtual/jpeg:0=[${MULTILIB_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+       default
+
+       sed -i -e 's:-Werror::' \
+               configure.ac || die
+
+       eautoreconf
+
+       # prevent "stat heif-test.go: no such file or directory"
+       multilib_copy_sources
+}
+
+multilib_src_configure() {
+       local myeconfargs=(
+               $(use_enable threads multithreading)
+               $(use_enable static-libs static)
+       )
+       ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+       find "${ED}" -name '*.la' -delete || die
+       if ! use static-libs ; then
+               find "${ED}" -name "*.a" -delete || die
+       fi
+}
index d9ed4b6306218dda9292a95f8f36ba98826be299..a03be0af6d3d3066cf15f96c91fba5646b84257a 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="7"
@@ -17,17 +17,16 @@ DESCRIPTION="ISO/IEC 23008-12:2017 HEIF file format decoder and encoder"
 HOMEPAGE="https://github.com/strukturag/libheif"
 
 LICENSE="GPL-3"
-SLOT="0/1.3.9999"
-IUSE="static-libs +threads"
+SLOT="0/1.4"
+IUSE="static-libs test +threads"
 
-# Doesn't yet support libjpeg-turbo-2, https://github.com/strukturag/libheif/issues/70
+BDEPEND="test? ( dev-lang/go )"
 DEPEND="
        media-libs/libde265:=[${MULTILIB_USEDEP}]
        media-libs/libpng:0=[${MULTILIB_USEDEP}]
        media-libs/x265:=[${MULTILIB_USEDEP}]
        sys-libs/zlib:=[${MULTILIB_USEDEP}]
        virtual/jpeg:0=[${MULTILIB_USEDEP}]
-       !>=media-libs/libjpeg-turbo-2
 "
 RDEPEND="${DEPEND}"
 
@@ -38,6 +37,9 @@ src_prepare() {
                configure.ac || die
 
        eautoreconf
+
+       # prevent "stat heif-test.go: no such file or directory"
+       multilib_copy_sources
 }
 
 multilib_src_configure() {