dev-cpp/catch: Drop old
authorMichał Górny <mgorny@gentoo.org>
Thu, 2 Nov 2017 08:08:10 +0000 (09:08 +0100)
committerMichał Górny <mgorny@gentoo.org>
Thu, 2 Nov 2017 08:45:37 +0000 (09:45 +0100)
dev-cpp/catch/Manifest
dev-cpp/catch/catch-1.9.7.ebuild [deleted file]
dev-cpp/catch/catch-2.0.0_pre3.ebuild [deleted file]

index 78c16bdcfba25d9719895c12092cf8db97731580..aabddf2eb944b60132d6efe3a4680683a7640597 100644 (file)
@@ -1,5 +1,3 @@
 DIST Catch-1.10.0.tar.gz 375205 SHA256 cb752cbc8033d7c967d6bd7bc3eed428f6d05f2511945db819d4a18a46853ada SHA512 07ea6c8fbef849000c69009478fc895fe520420d835a57881b832f8181ca28f04030027ab0f8614d590cff1c36d06598bd4f5723f44e252c3a2566da1be1341e WHIRLPOOL 74bc82eecbafa289c3abec540ebc47b0239eaf6224eaf6d408a88871e03338994d361194f6d92b15096f3c2a0672a24af424db5f490923be3638d1ed0f17a355
 DIST Catch-1.11.0.tar.gz 376132 SHA256 9e6111577e6dad2513a4229355f162023568af6a352d303367930758bed60f30 SHA512 33085c2671f78c7562eace909564b2730eabcaf4490cd463402e66ab4ac2be1fe4fe360916c11aa589ba4a010622444126ee2ae747783b5869b5d7276361f132 WHIRLPOOL b6d02053ce4eea0242cfe4d4fd5f5842b9279fc804c69837d7a2f9b652a1b2f768912fc10a20dae148757c9ff6aabdcf69daf6e85e652165871e58891ab57ef5
-DIST Catch-1.9.7.tar.gz 371816 SHA256 751090d755072777c5bb98de6ead1f7919ea239d4b77bb028fb7b06624ec0d7a SHA512 573d324b3e0ffe1026bdd10410a9299eff6d3e0a316b2b84c687dc993fb33570620e26107667ce8b59ab66844cfbc39526ed6ba4e9dd1ba529c6b21ebd274b63 WHIRLPOOL 1d3bcf6b2a3d8af6fba7ded0e92d7381857360a4bbf2dd689474408c52612f874da35579ad0adaf13679e1d8aaddee101274cd29070a5a51d58e7d52b76473f2
-DIST Catch-2.0.0-develop.3.tar.gz 381015 SHA256 c482fd4f0730cb82a05b1fc3eeee1beb599c5ae43c33719f5875cb23fa745b8f SHA512 52e6234379a435e7ddf3ee82a0689120a498f6be3c19dce9bf0a32059caa0a259fbc28c0e4f2e53841636874140970ec8cf7f15818ddfa9a1a5a80bc2922d0f0 WHIRLPOOL 537801b6c8f50a96f4f6a1594d6660a48e01e54ea83646a90e4d5c559f1f6ee6f582023f8d88bd69ad983035e3bacb0257ccaf1167eaa70b2e9302d031c07ded
 DIST Catch-2.0.0-develop.6.tar.gz 395416 SHA256 c66a7ecd0710ed27663a122f388872563456f83df654d22cc6a56a76315c59d3 SHA512 079172f063da06453d434d1b74b9a4ffeb45b40c90657ea410d6695756f23c581b1d574a88ab6537082df4e6e703e7bc9ce9084653abdc2a7033018e65a1bf5e WHIRLPOOL 9b7e2a72d43e52af3329f7f25e578dc07cdd1a81cf43dcbd0e22be68d56fa96595f1ece91769c14c006e2c64aa526cec1a70fa59a067f0c8a022851ece927af0
diff --git a/dev-cpp/catch/catch-1.9.7.ebuild b/dev-cpp/catch/catch-1.9.7.ebuild
deleted file mode 100644 (file)
index dd8e74f..0000000
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils
-
-DESCRIPTION="Modern C++ header-only framework for unit-tests"
-HOMEPAGE="https://github.com/philsquared/Catch"
-SRC_URI="https://github.com/philsquared/Catch/archive/v${PV}.tar.gz -> ${P^}.tar.gz"
-
-LICENSE="Boost-1.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-S=${WORKDIR}/${P^}
-
-# CMake is only used to build & run tests, so override phases
-src_configure() { :; }
-src_compile() { :; }
-
-src_test() {
-       cmake-utils_src_configure
-       cmake-utils_src_compile
-       cmake-utils_src_test
-}
-
-src_install() {
-       # same location as used in fedora
-       insinto /usr/include/catch
-       doins -r include/.
-       dodoc -r docs/.
-}
diff --git a/dev-cpp/catch/catch-2.0.0_pre3.ebuild b/dev-cpp/catch/catch-2.0.0_pre3.ebuild
deleted file mode 100644 (file)
index 62d91b8..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils
-
-MY_PV=${PV/_pre/-develop.}
-MY_P=${PN^}-${MY_PV}
-
-DESCRIPTION="Modern C++ header-only framework for unit-tests"
-HOMEPAGE="https://github.com/philsquared/Catch"
-SRC_URI="https://github.com/philsquared/Catch/archive/v${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
-
-LICENSE="Boost-1.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-S=${WORKDIR}/${MY_P}
-
-# CMake is only used to build & run tests, so override phases
-src_configure() { :; }
-src_compile() { :; }
-
-src_test() {
-       cmake-utils_src_configure
-       cmake-utils_src_compile
-       cmake-utils_src_test
-}
-
-src_install() {
-       # same location as used in fedora
-       insinto /usr/include/catch
-       doins -r include/.
-       dodoc -r docs/.
-}