Version bump, thanks to Jon Hood <squinky86 at gmail dot com> for the ebuild, bug...
authorRaúl Porcel <armin76@gentoo.org>
Thu, 15 Mar 2007 12:50:44 +0000 (12:50 +0000)
committerRaúl Porcel <armin76@gentoo.org>
Thu, 15 Mar 2007 12:50:44 +0000 (12:50 +0000)
Package-Manager: portage-2.1.2.2

net-p2p/ghostwhitecrab/ChangeLog
net-p2p/ghostwhitecrab/files/digest-ghostwhitecrab-0.9.9 [new file with mode: 0644]
net-p2p/ghostwhitecrab/ghostwhitecrab-0.9.9.ebuild [new file with mode: 0644]

index f0b3640df9f2563c5ac938edc29df77756cd99e5..e5bed6969a478218a6df9939406aeefd8aef821a 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for net-p2p/ghostwhitecrab
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/ghostwhitecrab/ChangeLog,v 1.9 2007/01/21 17:12:06 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ghostwhitecrab/ChangeLog,v 1.10 2007/03/15 12:50:44 armin76 Exp $
+
+*ghostwhitecrab-0.9.9 (15 Mar 2007)
+
+  15 Mar 2007; Raúl Porcel <armin76@gentoo.org>
+  +ghostwhitecrab-0.9.9.ebuild:
+  Version bump, thanks to Jon Hood <squinky86 at gmail dot com> for the
+  ebuild, bug 170991
 
   21 Jan 2007; Raúl Porcel <armin76@gentoo.org>
   -ghostwhitecrab-0.9.1.ebuild, -ghostwhitecrab-0.9.2.ebuild:
diff --git a/net-p2p/ghostwhitecrab/files/digest-ghostwhitecrab-0.9.9 b/net-p2p/ghostwhitecrab/files/digest-ghostwhitecrab-0.9.9
new file mode 100644 (file)
index 0000000..972b806
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 868b2800bc675f9226d6a668030a8aa9 gwc-0.9.9.tar.bz2 177226
+RMD160 95f97a1398a4f1f99554d9ff43281ef21d3f3790 gwc-0.9.9.tar.bz2 177226
+SHA256 bb910b5f524d21c3191414568c963af259d2b6298fe87fa09a468ca2be86ffce gwc-0.9.9.tar.bz2 177226
diff --git a/net-p2p/ghostwhitecrab/ghostwhitecrab-0.9.9.ebuild b/net-p2p/ghostwhitecrab/ghostwhitecrab-0.9.9.ebuild
new file mode 100644 (file)
index 0000000..23147f1
--- /dev/null
@@ -0,0 +1,84 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ghostwhitecrab/ghostwhitecrab-0.9.9.ebuild,v 1.1 2007/03/15 12:50:44 armin76 Exp $
+
+inherit eutils versionator
+
+IUSE="ipv6 threads zlib"
+
+MY_PN="gwc"
+MY_P="${MY_PN}-${PV}"
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="stand-alone gwebcache daemon"
+HOMEPAGE="http://www.ghostwhitecrab.com/crab/"
+SRC_URI="http://www.ghostwhitecrab.com/crab/${MY_P}.tar.bz2"
+LICENSE="as-is FDL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+
+DEPEND=">=sys-apps/sed-4
+       sys-libs/zlib
+       virtual/libc"
+RDEPEND=""
+
+pkg_setup() {
+       enewgroup gwc
+       enewuser gwc -1 /bin/bash /dev/null gwc
+}
+
+src_unpack() {
+       unpack ${A}
+       cd ${S}
+       sed -i -e 's:#User:User:g' examples/example.conf
+       sed -i -e 's:#Group:Group:g' examples/example.conf
+       sed -i -e 's:~gwc/db:/usr/share/gwc:g' examples/example.conf
+       sed -i -e 's:#data_template\t\t/path/to/data_template:data_template\t\t/usr/share/gwc/data_template:g' examples/example.conf
+       sed -i -e 's:#base_template\t\t/path/to/base_template:base_template\t\t/usr/share/gwc/base_template:g' examples/example.conf
+       sed -i -e 's:#listen_address\t\t:listen_address\t\t:g' examples/example.conf
+       sed -i -e 's:~gwc/logs:/var/log/gwc:g' examples/example.conf
+       sed -i -e 's:~gwc/cores:/var/log/gwc:g' examples/example.conf
+       sed -i -e 's:sleep 1::g' config.sh
+}
+
+src_compile() {
+       # this is not a standard configure script, so can't use the standard
+       # use_* functions
+       local myconf
+       use threads && myconf="--use-threads ${myconf}"
+       use ipv6 || myconf="--disable-ipv6 ${myconf}"
+       use zlib || myconf="--disable-zlib ${myconf}"
+       ./config.sh ${myconf} || die
+       emake || die
+}
+
+src_install() {
+       dobin src/gwc
+       dodir /etc/${PN}
+       insinto /etc/${PN}
+       newins examples/example.conf gwc.conf
+       dodir /usr/share/gwc
+       touch ${D}/usr/share/gwc/peer_cache
+       touch ${D}/usr/share/gwc/urls.good
+       touch ${D}/usr/share/gwc/urls.bad
+       insinto /usr/share/gwc
+       newins examples/data_html.template data_template
+       newins examples/base_html.template base_template
+       chown -R gwc:gwc ${D}/usr/share/gwc
+       dodir /var/log/gwc
+       touch ${D}/var/log/gwc/main.log
+       touch ${D}/var/log/gwc/access.log
+       touch ${D}/var/log/gwc/dns.log
+       touch ${D}/var/log/gwc/checks.log
+       chown -R gwc:gwc ${D}/var/log/gwc
+       exeinto /etc/init.d
+       newexe ${FILESDIR}/gwc.init gwc
+       dohtml doc/*.html doc/*.css doc/specs/*.html
+       dodoc doc/specs/*.txt examples/*
+}
+
+pkg_postinst() {
+       einfo "Please set the \"Location\" of your cache in /etc/${PN}/gwc.conf"
+       einfo "and submit your cache to:"
+       einfo "\thttp://gcachescan.jonatkins.com/"
+}