dev-python/clang-python: Reorder ebuild vars in 9+
authorMichał Górny <mgorny@gentoo.org>
Sat, 21 Sep 2019 08:32:45 +0000 (10:32 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sat, 21 Sep 2019 09:15:27 +0000 (11:15 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/clang-python/clang-python-10.0.0.9999.ebuild
dev-python/clang-python/clang-python-9.0.0.9999.ebuild
dev-python/clang-python/clang-python-9.0.0.ebuild

index ce6a903df4ab7a32de1bda3df8ab22919bc22999..5a65d445f01fc3d24301b4c61eb20d4939befbc2 100644 (file)
@@ -9,6 +9,8 @@ inherit git-r3 python-r1
 DESCRIPTION="Python bindings for sys-devel/clang"
 HOMEPAGE="https://llvm.org/"
 SRC_URI=""
+S=${WORKDIR}/${P}/bindings/python
+
 EGIT_REPO_URI="https://git.llvm.org/git/clang.git
        https://github.com/llvm-mirror/clang.git"
 
@@ -16,8 +18,8 @@ LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
 SLOT="0"
 KEYWORDS=""
 IUSE="test"
-RESTRICT="!test? ( test )"
 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
 
 # The module is opening libclang.so directly, and doing some blasphemy
 # on top of it.
@@ -28,8 +30,6 @@ RDEPEND="
        ${PYTHON_DEPS}"
 DEPEND="${RDEPEND}"
 
-S=${WORKDIR}/${P}/bindings/python
-
 src_unpack() {
        git-r3_fetch
        git-r3_checkout '' '' '' bindings/python
index 70de2ed55129a7b97aabaffce998da400fb440c2..d1c47b42ebfc99e4c3d2749da0913b26e56c467f 100644 (file)
@@ -9,6 +9,8 @@ inherit git-r3 python-r1
 DESCRIPTION="Python bindings for sys-devel/clang"
 HOMEPAGE="https://llvm.org/"
 SRC_URI=""
+S=${WORKDIR}/${P}/bindings/python
+
 EGIT_REPO_URI="https://git.llvm.org/git/clang.git
        https://github.com/llvm-mirror/clang.git"
 EGIT_BRANCH="release_90"
@@ -17,8 +19,8 @@ LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
 SLOT="0"
 KEYWORDS=""
 IUSE="test"
-RESTRICT="!test? ( test )"
 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
 
 # The module is opening libclang.so directly, and doing some blasphemy
 # on top of it.
@@ -29,8 +31,6 @@ RDEPEND="
        ${PYTHON_DEPS}"
 DEPEND="${RDEPEND}"
 
-S=${WORKDIR}/${P}/bindings/python
-
 src_unpack() {
        git-r3_fetch
        git-r3_checkout '' '' '' bindings/python
index 6583d35ad1314876fc4524003901f3979ca27ad9..63f0e576f048b8339b73a87ce5799d1a3225a0b1 100644 (file)
@@ -10,13 +10,14 @@ MY_P=cfe-${PV/_/}.src
 DESCRIPTION="Python bindings for sys-devel/clang"
 HOMEPAGE="https://llvm.org/"
 SRC_URI="https://releases.llvm.org/${PV}/${MY_P}.tar.xz"
+S=${WORKDIR}/${MY_P}/bindings/python
 
 LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
 SLOT="0"
 KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-fbsd"
 IUSE="test"
-RESTRICT="!test? ( test )"
 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
 
 # The module is opening libclang.so directly, and doing some blasphemy
 # on top of it.
@@ -27,8 +28,6 @@ RDEPEND="
        ${PYTHON_DEPS}"
 DEPEND="${RDEPEND}"
 
-S=${WORKDIR}/${MY_P}/bindings/python
-
 src_unpack() {
        einfo "Unpacking parts of ${MY_P}.tar.xz ..."
        tar -xJf "${DISTDIR}/${MY_P}.tar.xz" "${MY_P}/bindings/python" || die