net-p2p/torrentinfo: add Python 3.8 support, fix dependencies
authorLouis Sautier <sbraz@gentoo.org>
Thu, 23 Apr 2020 18:41:58 +0000 (20:41 +0200)
committerLouis Sautier <sbraz@gentoo.org>
Thu, 23 Apr 2020 18:42:57 +0000 (20:42 +0200)
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Louis Sautier <sbraz@gentoo.org>
net-p2p/torrentinfo/torrentinfo-1.8.6-r2.ebuild

index fb96961121366d26092f10fd991ac24cba57d684..47fe1ceaf0264d5aa2abd8976b810a1788e40d7a 100644 (file)
@@ -2,7 +2,9 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
-PYTHON_COMPAT=( pypy3 python3_{6,7} )
+PYTHON_COMPAT=( pypy3 python3_{6,7,8} )
+# The package uses distutils
+DISTUTILS_USE_SETUPTOOLS=no
 
 inherit distutils-r1
 
@@ -17,7 +19,6 @@ IUSE="test"
 RESTRICT="!test? ( test )"
 
 BDEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
        test? ( dev-python/nose[${PYTHON_USEDEP}] )
 "