www-misc/urlwatch: bump to 2.18
authorLouis Sautier <sbraz@gentoo.org>
Sun, 3 May 2020 21:14:13 +0000 (23:14 +0200)
committerLouis Sautier <sbraz@gentoo.org>
Sun, 3 May 2020 21:14:46 +0000 (23:14 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Louis Sautier <sbraz@gentoo.org>
www-misc/urlwatch/Manifest
www-misc/urlwatch/urlwatch-2.18.ebuild [new file with mode: 0644]

index baa34b18c12fbc4102e7c9bb5d94d63f773f15ea..8ad3d3c9768105cf50d8a8e42d46a1ba6eaa5a62 100644 (file)
@@ -1 +1,2 @@
 DIST urlwatch-2.17.tar.gz 44178 BLAKE2B 46163b3305a50c3b5165da8f794c252aeb0a3581f16ba04cc1f0d920066accd02f7eba47718012e2ac0071f6bfa31019777a28840179a28a7fe365ae2e8f1d2c SHA512 635bca7e55641dd73447f5ec9ad429539decfaa8a1c19ab073c3bd46acfc518fa6012d855e0c37dd78654da28acf1446f580def611bcb85ae94fe13f567e3613
+DIST urlwatch-2.18.tar.gz 48268 BLAKE2B e595a6ed27637463f14f92ecafd123eb0c7cef7102cc35ebbc3334804f7e09cc5f933aa2d54e24acd74a1419d6a8683a0d5fb2456b35ae0797c3d8a12efc33de SHA512 4b44a78fe7f2be6f507487ad5de57d79aa55ee790b29b97f2a364c0f3b58828fea5eb2b08235c15cafd3839b9261a7f148ebc9bceb5bedd1ff8319f7f039bb23
diff --git a/www-misc/urlwatch/urlwatch-2.18.ebuild b/www-misc/urlwatch/urlwatch-2.18.ebuild
new file mode 100644 (file)
index 0000000..4c0c01c
--- /dev/null
@@ -0,0 +1,60 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+# The package uses entry points but setup.py is weird
+# so the eclass doesn't detect it
+DISTUTILS_USE_SETUPTOOLS=manual
+
+inherit distutils-r1
+
+DESCRIPTION="A tool for monitoring webpages for updates"
+HOMEPAGE="https://thp.io/2008/urlwatch/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+       dev-python/appdirs[${PYTHON_USEDEP}]
+       dev-python/cssselect[${PYTHON_USEDEP}]
+       dev-python/keyring[${PYTHON_USEDEP}]
+       dev-python/lxml[${PYTHON_USEDEP}]
+       dev-python/minidb[${PYTHON_USEDEP}]
+       dev-python/pyyaml[${PYTHON_USEDEP}]
+       dev-python/requests[${PYTHON_USEDEP}]
+       dev-python/setuptools[${PYTHON_USEDEP}]
+"
+BDEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               ${RDEPEND}
+               dev-python/nose[${PYTHON_USEDEP}]
+               dev-python/pycodestyle[${PYTHON_USEDEP}]
+       )
+"
+
+DOCS=( CHANGELOG.md README.md )
+
+distutils_enable_tests nose
+
+pkg_postinst() {
+       if [[ -z "${REPLACING_VERSIONS}" ]]; then
+               if ! has_version dev-python/chump; then
+                       elog "Install 'dev-python/chump' to enable Pushover" \
+                               "notifications support"
+               fi
+               if ! has_version dev-python/pushbullet-py; then
+                       elog "Install 'dev-python/pushbullet-py' to enable" \
+                               "Pushbullet notifications support"
+               fi
+               elog "HTML parsing can be improved by installing one of the following packages"
+               elog "and changing the html2text subfilter parameter:"
+               elog "dev-python/beautifulsoup:4"
+               elog "app-text/html2text"
+               elog "dev-python/html2text"
+               elog "www-client/lynx"
+       fi
+}