dev-python/cryptography: Replace virts with cond deps
authorMichał Górny <mgorny@gentoo.org>
Mon, 16 Mar 2020 20:53:22 +0000 (21:53 +0100)
committerMichał Górny <mgorny@gentoo.org>
Mon, 16 Mar 2020 20:56:40 +0000 (21:56 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/cryptography/cryptography-2.6.1-r1.ebuild
dev-python/cryptography/cryptography-2.8-r1.ebuild

index 1cfcb46fdc9605f817e735b260af5b61bb52ec67..281e405e9f4e684aa154a1a62482e7dbf5d245b8 100644 (file)
@@ -37,10 +37,14 @@ RDEPEND="
        >=dev-python/asn1crypto-0.21.0[${PYTHON_USEDEP}]
        dev-python/setuptools[${PYTHON_USEDEP}]
        >=dev-python/six-1.4.1[${PYTHON_USEDEP}]
-       virtual/python-enum34[${PYTHON_USEDEP}]
-       virtual/python-ipaddress[${PYTHON_USEDEP}]
-       $(python_gen_cond_dep '>=dev-python/cffi-1.8:=[${PYTHON_USEDEP}]' 'python*')
-       $(python_gen_cond_dep '!~dev-python/cffi-1.11.3[${PYTHON_USEDEP}]' 'python*')
+       $(python_gen_cond_dep '
+               dev-python/enum34[${PYTHON_USEDEP}]
+               dev-python/ipaddress[${PYTHON_USEDEP}]
+       ' -2)
+       $(python_gen_cond_dep '
+               >=dev-python/cffi-1.8:=[${PYTHON_USEDEP}]
+               !~dev-python/cffi-1.11.3[${PYTHON_USEDEP}]
+       ' 'python*')
        "
 DEPEND="${RDEPEND}
        >=dev-python/setuptools-1.0[${PYTHON_USEDEP}]
index 7238fe0f9b47efba1a44bff2106094dac653412f..2b7b392c0bd3d5d4fc41d49cc81af9691772aaec 100644 (file)
@@ -38,10 +38,14 @@ RDEPEND="
        idna? ( >=dev-python/idna-2.1[${PYTHON_USEDEP}] )
        dev-python/setuptools[${PYTHON_USEDEP}]
        >=dev-python/six-1.4.1[${PYTHON_USEDEP}]
-       virtual/python-enum34[${PYTHON_USEDEP}]
-       virtual/python-ipaddress[${PYTHON_USEDEP}]
-       $(python_gen_cond_dep '>=dev-python/cffi-1.8:=[${PYTHON_USEDEP}]' 'python*')
-       $(python_gen_cond_dep '!~dev-python/cffi-1.11.3[${PYTHON_USEDEP}]' 'python*')
+       $(python_gen_cond_dep '
+               dev-python/enum34[${PYTHON_USEDEP}]
+               dev-python/ipaddress[${PYTHON_USEDEP}]
+       ' -2)
+       $(python_gen_cond_dep '
+               >=dev-python/cffi-1.8:=[${PYTHON_USEDEP}]
+               !~dev-python/cffi-1.11.3[${PYTHON_USEDEP}]
+       ' 'python*')
        "
 DEPEND="${RDEPEND}
        >=dev-python/setuptools-1.0[${PYTHON_USEDEP}]