media-libs/libsmf: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Fri, 13 Dec 2019 00:42:45 +0000 (01:42 +0100)
committerDavid Seifert <soap@gentoo.org>
Fri, 13 Dec 2019 00:42:45 +0000 (01:42 +0100)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
media-libs/libsmf/libsmf-1.3.ebuild

index e737d43b44065ab244e976f4562fb637029ac571..374d68ee10857a77e1f113fe1d27f6c38aff64ab 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=4
+EAPI=7
 
-inherit autotools-utils
+inherit autotools
 
 DESCRIPTION="Standard MIDI File format library"
 HOMEPAGE="http://libsmf.sourceforge.net/api/"
@@ -12,32 +12,34 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
 LICENSE="BSD"
 SLOT="0"
 KEYWORDS="amd64 ~arm ppc ppc64 x86"
-IUSE="doc readline static-libs"
+IUSE="doc readline"
 
-RDEPEND=">=dev-libs/glib-2.2:2
-       readline? ( sys-libs/readline )"
-DEPEND="${RDEPEND}
-       doc? ( app-doc/doxygen )
-       virtual/pkgconfig"
-
-DOCS=( NEWS TODO )
+RDEPEND="
+       dev-libs/glib:2
+       readline? ( sys-libs/readline:= )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+       virtual/pkgconfig
+       doc? ( app-doc/doxygen )"
 
 src_configure() {
-       local myeconfargs=(
+       econf \
+               --disable-static \
                $(use_with readline)
-       )
-       autotools-utils_src_configure
 }
 
 src_compile() {
-       autotools-utils_src_compile
+       default
 
-       if use doc ; then
+       if use doc; then
                doxygen doxygen.cfg || die
        fi
 }
 
 src_install() {
-       autotools-utils_src_install
-       use doc && dohtml -r api
+       use doc && local HTML_DOCS=( api )
+       default
+
+       # no static archives
+       find "${D}" -name '*.la' -delete || die
 }