app-doc/blas-docs: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Wed, 16 Oct 2019 10:13:12 +0000 (12:13 +0200)
committerDavid Seifert <soap@gentoo.org>
Wed, 16 Oct 2019 10:13:12 +0000 (12:13 +0200)
Bug: https://bugs.gentoo.org/697388
Package-Manager: Portage-2.3.77, Repoman-2.3.17
Signed-off-by: David Seifert <soap@gentoo.org>
app-doc/blas-docs/blas-docs-3.1.1.ebuild

index d034c041c60244b4eb92b68e22dd18b7185b1dd6..899fd9c1c85731160afaa7e61be7f9538f76c926 100644 (file)
@@ -1,7 +1,7 @@
 # Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
+EAPI=7
 
 DESCRIPTION="Documentation reference and man pages for blas implementations"
 HOMEPAGE="http://www.netlib.org/blas"
@@ -17,13 +17,13 @@ IUSE=""
 S=${WORKDIR}/lapack-${PV}/manpages
 
 src_install() {
-       # rename because doman do not yet understand manl files
-       # Not all systems have the rename command, like say FreeBSD
-       local f= t=
+       # rename because doman does not yet understand manl files
+       local f t
        for f in blas/man/manl/*.l; do
                t="${f%%.l}.n"
-               mv "${f}" "${t}"
+               mv "${f}" "${t}" || die
        done
-       doman blas/man/manl/*.n || die "doman failed"
-       dodoc README "${DISTDIR}"/blas{-report,qr}.ps || die "dodoc failed"
+
+       doman blas/man/manl/*.n
+       dodoc README "${DISTDIR}"/blas{-report,qr}.ps
 }