dev-python/pytest-helpers-namespace-2019.1.8-r1: revbump, add py38, tests
authorPatrick McLean <patrick.mclean@sony.com>
Tue, 21 Apr 2020 01:41:07 +0000 (18:41 -0700)
committerPatrick McLean <chutzpah@gentoo.org>
Wed, 22 Apr 2020 01:13:19 +0000 (18:13 -0700)
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
dev-python/pytest-helpers-namespace/Manifest
dev-python/pytest-helpers-namespace/pytest-helpers-namespace-2019.1.8-r1.ebuild [new file with mode: 0644]
dev-python/pytest-helpers-namespace/pytest-helpers-namespace-2019.1.8.ebuild [deleted file]

index 3b40f6845dea30c6bd28c5e0aa0628cefbd4b28b..89648fcfe50f9470f6eacd0ca6911d9612ea0bd1 100644 (file)
@@ -1 +1 @@
-DIST pytest-helpers-namespace-2019.1.8.tar.gz 5487 BLAKE2B 201e2e34f60baf95ce33f8cb5d3d8ce5465b4140e68c16f4802ba5225e28c4506c608dfc6ff4a36fddde30c7972a8c175ead976a11a731e2bfbc33e4b06cc04e SHA512 47b7f7c6638f4f3f0248722d4134b73357acb091f02cc1302d32894223d5ec06fd5382db207ae524f62749f2ebc53cf32d27eb8890d12baf250cd29dc6378a55
+DIST pytest-helpers-namespace-v2019.1.8.tar.gz 10274 BLAKE2B 1d232817e99909738f7f37466ba22fbeadf75f4fbfdd9b61790dd79418bedbce4ee219e5102ee2db1709ba991e323ce6edffc68c4e3a657c58cb628b505de098 SHA512 d5f4db3ece8b0e1719c4d1213a5e07a3c53257b089d3d74f90cf86f21a7951983a95286c7753f5e9486acc7e482d79c2a95d5a7b8eb22e19c7048db99fa3c421
diff --git a/dev-python/pytest-helpers-namespace/pytest-helpers-namespace-2019.1.8-r1.ebuild b/dev-python/pytest-helpers-namespace/pytest-helpers-namespace-2019.1.8-r1.ebuild
new file mode 100644 (file)
index 0000000..1883af6
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Provides a helpers pytest namespace"
+HOMEPAGE="https://github.com/saltstack/pytest-helpers-namespace"
+SRC_URI="https://github.com/saltstack/${PN}/archive/v${PV}.tar.gz -> ${PN}-v${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+       dev-python/pytest[${PYTHON_USEDEP}]
+       test? (
+               dev-python/pytest-forked[${PYTHON_USEDEP}]
+       )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+       sed -r -e 's:(foo|bar):namespace_\1:g' \
+               -i tests/test_helpers_namespace.py || die
+       distutils-r1_python_prepare_all
+}
+
+python_test() {
+       distutils_install_for_testing
+       pytest --forked -vv || die "Tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/pytest-helpers-namespace/pytest-helpers-namespace-2019.1.8.ebuild b/dev-python/pytest-helpers-namespace/pytest-helpers-namespace-2019.1.8.ebuild
deleted file mode 100644 (file)
index 5df845c..0000000
+++ /dev/null
@@ -1,19 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Provides a helpers pytest namespace"
-HOMEPAGE="https://github.com/saltstack/pytest-helpers-namespace"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"