dev-libs/libstrophe: add new version 0.9.3
authorAndrey Utkin <andrey_utkin@gentoo.org>
Mon, 28 Oct 2019 18:43:57 +0000 (18:43 +0000)
committerAndrey Utkin <andrey_utkin@gentoo.org>
Mon, 28 Oct 2019 19:01:42 +0000 (19:01 +0000)
Copied from 0.9.2.
The only change is that libressl-related patch has been dropped, as
there is now upstream support for libressl.

Package-Manager: Portage-2.3.66, Repoman-2.3.16
Signed-off-by: Andrey Utkin <andrey_utkin@gentoo.org>
dev-libs/libstrophe/Manifest
dev-libs/libstrophe/libstrophe-0.9.3.ebuild [new file with mode: 0644]

index e5c1bc327adccdf6fcf72871c11646f531f7ea03..2e913cf0bd1f51adabf423b5e65c908de4409cf1 100644 (file)
@@ -1 +1,2 @@
 DIST libstrophe-0.9.2.tar.gz 500459 BLAKE2B 0b1f6f1daac1215bcdcbde0e54264b98f5a863de339500826f625f8c5e8143ce7200fb251d04248715e9a8b6621a4360e7ca2780bf4684d916ec13361b5f6fcc SHA512 a0129c49ca574afaefa77c412143571af2eb1100c7d737d497b65d44680d35e2404ee2d4d4e1378b06ac1bcc5c587f505f79fea9251af1cbb36afd990d48570d
+DIST libstrophe-0.9.3.tar.gz 502449 BLAKE2B 662b0c329b0bf7d7f34fc80bf0608b921fa1ad54c8277e88f23f3ed17d0892dc7e3d9bcaaa9707306801e9254bba4a127390025ab95e1d9d850c299a7b26d980 SHA512 9c8ba980f532c5576c2c5a9e3cdca9f833ec78debcb06b17e2f534de0e710ec416b997b0498be77a89fa7f57187456edb1d602993c695a5e738718ea593697a5
diff --git a/dev-libs/libstrophe/libstrophe-0.9.3.ebuild b/dev-libs/libstrophe/libstrophe-0.9.3.ebuild
new file mode 100644 (file)
index 0000000..5323315
--- /dev/null
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+DESCRIPTION="A simple, lightweight C library for writing XMPP clients"
+HOMEPAGE="http://strophe.im/libstrophe/"
+SRC_URI="https://github.com/strophe/${PN}/releases/download/${PV}/${P}.tar.gz"
+LICENSE="|| ( MIT GPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc expat libressl"
+
+RDEPEND="
+       expat? ( dev-libs/expat )
+       !expat? ( dev-libs/libxml2:2 )
+       libressl? ( dev-libs/libressl:0= )
+       !libressl? ( dev-libs/openssl:0= )
+"
+DEPEND="${RDEPEND}
+       doc? ( app-doc/doxygen )
+"
+
+DOCS=( ChangeLog )
+
+src_configure() {
+       # shellcheck disable=SC2207
+       local myeconf=(
+               --enable-tls
+               $(use_with !expat libxml2)
+       )
+       econf "${myeconf[@]}"
+}
+src_compile() {
+       default
+       if use doc; then
+               doxygen || die
+               HTML_DOCS=( docs/html/* )
+       fi
+}
+
+src_install() {
+       default
+       use doc && dodoc -r examples
+       find "${D}" -name '*.la' -delete || die
+}