dev-lang/perl: Update upgrade prose to encourage depclean
authorKent Fredric <kentnl@gentoo.org>
Fri, 16 Sep 2016 20:47:53 +0000 (08:47 +1200)
committerKent Fredric <kentnl@gentoo.org>
Fri, 16 Sep 2016 21:19:51 +0000 (09:19 +1200)
Depcleans really do help a lot and you should do them lots.

Note: the 5.24.0-r1 version ( which is patched here ) is not displayed
to the user due to some mistakes made when flattening it, this will be
rectified in a future commit.

Note: Patching apparently "Old" eblits because due to a lack of clarity
on how eblits actually work, it turns out that all eblit-using
dev-lang/perl ebuilds are sourcing *BOTH* their own eblit entries *AND*
the eblit for v5016001!!.

The use of eblits here has made it impossible to clearly discern which
code is actually running, and that perl 5.22* and 5.20* actually work
at all is more a case of amazing amounts of good luck than actual
planning.

Package-Manager: portage-2.3.0

dev-lang/perl/files/eblits/pkg_setup-v50160001.eblit
dev-lang/perl/files/eblits/pkg_setup-v50220001.eblit
dev-lang/perl/files/eblits/pkg_setup-v50240001.eblit
dev-lang/perl/perl-5.24.0-r1.ebuild

index a7b734f4091d84bc6dc907ca45af6975bff64770..e46ffc2ae5734b5d0d9238bd45dfb9c3eb328b04 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -48,8 +48,18 @@ check_rebuild() {
        if has_version "<dev-lang/perl-${SHORT_PV}" ; then
                echo ""
                ewarn "UPDATE THE PERL MODULES:"
-               ewarn "After updating dev-lang/perl you must reinstall"
-               ewarn "the installed perl modules."
+               ewarn "After updating dev-lang/perl the installed Perl modules"
+               ewarn "have to be re-installed. In most cases, this is done automatically"
+               ewarn "by the package manager, but subsequent steps are still recommended"
+               ewarn "to ensure system consistency."
+               ewarn
+               ewarn "You should start with a depclean to remove any unused perl dependencies"
+               ewarn "that may confuse portage in future. Regular depcleans are also encouraged"
+               ewarn "as part of your regular update cycle, as that will keep perl upgrades working."
+               ewarn "Recommended: emerge --depclean -va"
+               ewarn
+               ewarn "You should then call perl-cleaner to clean up any old files and trigger any"
+               ewarn "remaining rebuilds portage may have missed."
                ewarn "Use: perl-cleaner --all"
        elif has_version dev-lang/perl ; then
                # doesnot work
index a2b09574d16322bac25a7a2086854bcc7e7746ed..e46ffc2ae5734b5d0d9238bd45dfb9c3eb328b04 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -48,10 +48,18 @@ check_rebuild() {
        if has_version "<dev-lang/perl-${SHORT_PV}" ; then
                echo ""
                ewarn "UPDATE THE PERL MODULES:"
-               ewarn "After updating dev-lang/perl the installed Perl modules will"
+               ewarn "After updating dev-lang/perl the installed Perl modules"
                ewarn "have to be re-installed. In most cases, this is done automatically"
-               ewarn "by the package manager, but you should still call perl-cleaner to"
-               ewarn "make sure your system is consistent."
+               ewarn "by the package manager, but subsequent steps are still recommended"
+               ewarn "to ensure system consistency."
+               ewarn
+               ewarn "You should start with a depclean to remove any unused perl dependencies"
+               ewarn "that may confuse portage in future. Regular depcleans are also encouraged"
+               ewarn "as part of your regular update cycle, as that will keep perl upgrades working."
+               ewarn "Recommended: emerge --depclean -va"
+               ewarn
+               ewarn "You should then call perl-cleaner to clean up any old files and trigger any"
+               ewarn "remaining rebuilds portage may have missed."
                ewarn "Use: perl-cleaner --all"
        elif has_version dev-lang/perl ; then
                # doesnot work
index 9ce8e992c3260733c2ba0a6dd26ef7db6642a5c5..87579449f2d0a7146433adb4dacedeb9ebdbc9f4 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -46,10 +46,18 @@ check_rebuild() {
        if has_version "<dev-lang/perl-${SHORT_PV}" ; then
                echo ""
                ewarn "UPDATE THE PERL MODULES:"
-               ewarn "After updating dev-lang/perl the installed Perl modules will"
+               ewarn "After updating dev-lang/perl the installed Perl modules"
                ewarn "have to be re-installed. In most cases, this is done automatically"
-               ewarn "by the package manager, but you should still call perl-cleaner to"
-               ewarn "make sure your system is consistent."
+               ewarn "by the package manager, but subsequent steps are still recommended"
+               ewarn "to ensure system consistency."
+               ewarn
+               ewarn "You should start with a depclean to remove any unused perl dependencies"
+               ewarn "that may confuse portage in future. Regular depcleans are also encouraged"
+               ewarn "as part of your regular update cycle, as that will keep perl upgrades working."
+               ewarn "Recommended: emerge --depclean -va"
+               ewarn
+               ewarn "You should then call perl-cleaner to clean up any old files and trigger any"
+               ewarn "remaining rebuilds portage may have missed."
                ewarn "Use: perl-cleaner --all"
        elif has_version dev-lang/perl ; then
                if (   use ithreads && ! has_version dev-lang/perl[ithreads] ) || \
index 0bd67107bde56c38e0e67aaa9a516163bdb31339..3086c8e7ed910bea1a9a1d83689c8617b688b145 100644 (file)
@@ -73,8 +73,16 @@ check_rebuild() {
                ewarn "UPDATE THE PERL MODULES:"
                ewarn "After updating dev-lang/perl the installed Perl modules"
                ewarn "have to be re-installed. In most cases, this is done automatically"
-               ewarn "by the package manager, but you should still call perl-cleaner to"
-               ewarn "make sure your system is consistent."
+               ewarn "by the package manager, but subsequent steps are still recommended"
+               ewarn "to ensure system consistency."
+               ewarn
+               ewarn "You should start with a depclean to remove any unused perl dependencies"
+               ewarn "that may confuse portage in future. Regular depcleans are also encouraged"
+               ewarn "as part of your regular update cycle, as that will keep perl upgrades working."
+               ewarn "Recommended: emerge --depclean -va"
+               ewarn
+               ewarn "You should then call perl-cleaner to clean up any old files and trigger any"
+               ewarn "remaining rebuilds portage may have missed."
                ewarn "Use: perl-cleaner --all"
        elif has_version dev-lang/perl ; then
                if (   use ithreads && ! has_version dev-lang/perl[ithreads] ) || \