app-text/libqxp: 0.0.1 version bump
authorAndreas Sturmlechner <asturm@gentoo.org>
Sun, 7 Jan 2018 09:39:22 +0000 (10:39 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sun, 7 Jan 2018 09:39:22 +0000 (10:39 +0100)
Package-Manager: Portage-2.3.19, Repoman-2.3.6

app-text/libqxp/Manifest
app-text/libqxp/libqxp-0.0.1.ebuild [new file with mode: 0644]

index a085eafda9a5726cc6f492b59b01ca0bca0a0baa..ced30e9da8e29e844ec96c321f41b39b9452c8a8 100644 (file)
@@ -1 +1,2 @@
 DIST libqxp-0.0.0.tar.xz 337292 BLAKE2B 16b59353f35d8a93d57600e0ad185755f5f072b41568886197684f65d9f10042e376ae3683f229ba9e526cc8af81b1c1c423defa00eccb3448611765eed7dbf6 SHA512 c92cb6298ea4643e29145732ff3b6df806f2d30c86ab4967e445dcbc8c43b6d9fdd17c30a3e6131b4f0f2a42135caa0137b61aac2ab2722528a08e1fd6c02df9
+DIST libqxp-0.0.1.tar.xz 340184 BLAKE2B 759e5d0fb5886485f4ebe4a6caa34d1d98dc623c0ae124c6666a1be5ce7fb73686fc83360712d59d020e4788b39aa57d32149b7641d71b73dde917df46617f17 SHA512 a03a9ada658a92f4d985cad91d467b3916334c74dc26c1e4de89e3929e0135ca0e9c7e7e18ce616ef56a67863ec19c2638494400785849017f9a4776df07c607
diff --git a/app-text/libqxp/libqxp-0.0.1.ebuild b/app-text/libqxp/libqxp-0.0.1.ebuild
new file mode 100644 (file)
index 0000000..7658d11
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Library parsing QuarkXpress documents"
+HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/${PN}"
+SRC_URI="https://dev-www.libreoffice.org/src/${PN}/${P}.tar.xz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc test tools"
+
+RDEPEND="
+       dev-libs/librevenge
+       dev-libs/icu:=
+"
+DEPEND="${RDEPEND}
+       dev-libs/boost
+       virtual/pkgconfig
+       doc? ( app-doc/doxygen )
+"
+
+src_configure() {
+       econf \
+               --disable-weffc \
+               $(use_enable debug) \
+               $(use_with doc docs) \
+               $(use_enable test tests) \
+               $(use_enable tools)
+}
+
+src_install() {
+       default
+       find "${D}" -name '*.la' -delete || die
+}