games-emulation/mednafen: Call pax-mark unconditionally
authorJames Le Cuirot <chewi@gentoo.org>
Mon, 28 Oct 2019 21:34:00 +0000 (21:34 +0000)
committerJames Le Cuirot <chewi@gentoo.org>
Mon, 28 Oct 2019 21:38:37 +0000 (21:38 +0000)
This is what we normally do.

Closes: https://bugs.gentoo.org/698276
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
games-emulation/mednafen/mednafen-0.9.46.ebuild
games-emulation/mednafen/metadata.xml

index a42d9936b35c5cf7fc871894258bb108f89bb0ad..e789c94b32409459554e481abdb2e527fc23e5ad 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -12,7 +12,7 @@ SRC_URI="https://mednafen.github.io/releases/files/${P}.tar.xz"
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
-IUSE="alsa altivec cjk debugger jack nls pax_kernel"
+IUSE="alsa altivec cjk debugger jack nls"
 
 RDEPEND="
        dev-libs/libcdio
@@ -108,8 +108,5 @@ src_configure() {
 src_install() {
        default
        dodoc Documentation/cheats.txt
-
-       if use pax_kernel; then
-               pax-mark m "${ED%/}"/usr/bin/mednafen || die
-       fi
+       pax-mark m "${ED}"usr/bin/mednafen
 }
index 0afad2b3f24efda9b01372d6d6ec8a92435a33dd..5c1044a50bb7e8857a6638cb9db40b39333fcd0a 100644 (file)
@@ -7,7 +7,6 @@
        </maintainer>
        <use>
                <flag name="debugger">Build with internal debugger</flag>
-               <flag name="pax_kernel">Triggers a paxmarking of the binary</flag>
        </use>
        <upstream>
                <remote-id type="sourceforge">mednafen</remote-id>