x11-libs/fltk: Drop USE=pdf (bug #536566).
authorJeroen Roovers <jer@gentoo.org>
Wed, 7 Oct 2015 04:56:05 +0000 (06:56 +0200)
committerJeroen Roovers <jer@gentoo.org>
Wed, 7 Oct 2015 04:56:05 +0000 (06:56 +0200)
Package-Manager: portage-2.2.22

x11-libs/fltk/fltk-1.3.3-r3.ebuild
x11-libs/fltk/fltk-1.3.9999.ebuild

index b55bc94cf959f43c51bd01c79acdbe2b893d9a8a..e4d4ae6ba26ca0fcbbb359eb10020ffc965fe474 100644 (file)
@@ -13,7 +13,7 @@ SRC_URI="http://fltk.org/pub/${PN}/${PV}/${P}-source.tar.gz"
 SLOT="1"
 LICENSE="FLTK LGPL-2"
 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos"
-IUSE="cairo debug doc examples games +opengl pdf static-libs +threads +xft +xinerama"
+IUSE="cairo debug doc examples games +opengl static-libs +threads +xft +xinerama"
 
 RDEPEND="
        >=media-libs/libpng-1.2:0
@@ -29,14 +29,7 @@ RDEPEND="
        xft? ( x11-libs/libXft )"
 DEPEND="${RDEPEND}
        x11-proto/xextproto
-       doc? (
-               app-doc/doxygen
-               pdf? (
-                       dev-texlive/texlive-fontutils
-                       dev-texlive/texlive-latex
-                       dev-texlive/texlive-latexextra
-               )
-       )
+       doc? ( app-doc/doxygen )
        xinerama? ( x11-proto/xineramaproto )"
 
 FLTK_INCDIR=${EPREFIX}/usr/include/fltk
@@ -99,12 +92,11 @@ src_configure() {
 
 src_compile() {
        default
+
        if use doc; then
                emake -C documentation html
-               if use pdf; then
-                       emake -C documentation pdf
-               fi
        fi
+
        if use games; then
                emake -C test blocks checkers sudoku
        fi
index ba25ae8969a7ac3dc2e6ec46db159741bbad6da8..3c620a6587bf1e6a8e5b5882757f61c204b22190 100644 (file)
@@ -15,7 +15,7 @@ ESVN_PASSWORD=""
 SLOT="1"
 LICENSE="FLTK LGPL-2"
 KEYWORDS=""
-IUSE="cairo debug doc examples games +opengl pdf static-libs +threads +xft +xinerama"
+IUSE="cairo debug doc examples games +opengl static-libs +threads +xft +xinerama"
 
 RDEPEND="
        >=media-libs/libpng-1.2:0
@@ -31,14 +31,7 @@ RDEPEND="
        xft? ( x11-libs/libXft )"
 DEPEND="${RDEPEND}
        x11-proto/xextproto
-       doc? (
-               app-doc/doxygen
-               pdf? (
-                       dev-texlive/texlive-fontutils
-                       dev-texlive/texlive-latex
-                       dev-texlive/texlive-latexextra
-               )
-       )
+       doc? ( app-doc/doxygen )
        xinerama? ( x11-proto/xineramaproto )"
 
 FLTK_INCDIR=${EPREFIX}/usr/include/fltk
@@ -102,12 +95,11 @@ src_configure() {
 
 src_compile() {
        default
+
        if use doc; then
                emake -C documentation html
-               if use pdf; then
-                       emake -C documentation pdf
-               fi
        fi
+
        if use games; then
                emake -C test blocks checkers sudoku
        fi