Version bump, remove old version
authorMatti Bickel <mabi@gentoo.org>
Tue, 14 Nov 2006 15:35:04 +0000 (15:35 +0000)
committerMatti Bickel <mabi@gentoo.org>
Tue, 14 Nov 2006 15:35:04 +0000 (15:35 +0000)
Package-Manager: portage-2.1.1-r1

x11-libs/fox/ChangeLog
x11-libs/fox/files/digest-fox-1.5.4
x11-libs/fox/files/digest-fox-1.6.19 [new file with mode: 0644]
x11-libs/fox/fox-1.6.19.ebuild [new file with mode: 0644]

index b2165b0de5a56471565808a873539d4b60bd6ae7..d15977c9aae1ee9e7f56dc396e92fb9a9d9660d5 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for x11-libs/fox
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/fox/ChangeLog,v 1.64 2006/11/14 13:36:25 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fox/ChangeLog,v 1.65 2006/11/14 15:35:04 mabi Exp $
+
+*fox-1.6.19 (14 Nov 2006)
+
+  14 Nov 2006; Matti Bickel <mabi@gentoo.org> -fox-1.6.14.ebuild,
+  +fox-1.6.19.ebuild:
+  Version bump, remove old version
 
   14 Nov 2006; Guy Martin <gmsoft@gentoo.org> fox-1.2.18-r1.ebuild:
   Stable on hppa.
index 7a95716853111fea0117a911a0f3bb1b42af0691..9a03feb491c734fb08fd3acc65950917d76b1069 100644 (file)
@@ -1 +1,3 @@
 MD5 b79f90be88d97ada86c46e1889d1c148 fox-1.5.4.tar.gz 4027866
+RMD160 173939c54571de6718d476f22ee118384bdc4596 fox-1.5.4.tar.gz 4027866
+SHA256 d2735b63b27c0d4b8d16f44c09d096ce812b9e528f3750440dfdd43b588c2be1 fox-1.5.4.tar.gz 4027866
diff --git a/x11-libs/fox/files/digest-fox-1.6.19 b/x11-libs/fox/files/digest-fox-1.6.19
new file mode 100644 (file)
index 0000000..aced62e
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 dacebd92c7aaaca936ae350e2d5d6ba7 fox-1.6.19.tar.gz 4334927
+RMD160 54dc946480083c45ce1b9a7838888cabfe0543b2 fox-1.6.19.tar.gz 4334927
+SHA256 be4f0cc939ef261f04f46010f05f22b1303f4058ce8eb1b1651378c24973ce88 fox-1.6.19.tar.gz 4334927
diff --git a/x11-libs/fox/fox-1.6.19.ebuild b/x11-libs/fox/fox-1.6.19.ebuild
new file mode 100644 (file)
index 0000000..646f929
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fox/fox-1.6.19.ebuild,v 1.1 2006/11/14 15:35:04 mabi Exp $
+
+inherit fox
+
+LICENSE="LGPL-2.1"
+SLOT="1.6"
+KEYWORDS="~x86 ~amd64 ~alpha ~hppa ~ppc ~ppc64 ~sparc"
+IUSE="bzip2 cups jpeg opengl png threads tiff truetype zlib"
+
+RDEPEND="x11-libs/libXrandr
+       x11-libs/libXcursor
+       x11-libs/fox-wrapper
+       bzip2? ( >=app-arch/bzip2-1.0.2 )
+       cups? ( net-print/cups )
+       jpeg? ( >=media-libs/jpeg-6b )
+       opengl? ( virtual/opengl virtual/glu )
+       png? ( >=media-libs/libpng-1.2.5 )
+       tiff? ( >=media-libs/tiff-3.5.7 )
+       truetype? ( =media-libs/freetype-2*
+               virtual/xft )
+       zlib? ( >=sys-libs/zlib-1.1.4 )"
+DEPEND="${RDEPEND}
+       x11-proto/xextproto
+       x11-libs/libXt"
+
+FOXCONF="$(use_enable bzip2 bz2lib) \
+       $(use_enable cups) \
+       $(use_enable jpeg) \
+       $(use_with opengl) \
+       $(use_enable png) \
+       $(use_enable threads threadsafe) \
+       $(use_enable tiff) \
+       $(use_with truetype xft) \
+       $(use_enable zlib)"