app-emulation/diskimage-builder: 2.25.0 bump
authorMatthew Thode <prometheanfire@gentoo.org>
Mon, 15 Jul 2019 12:58:16 +0000 (07:58 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Mon, 15 Jul 2019 12:58:31 +0000 (07:58 -0500)
Package-Manager: Portage-2.3.66, Repoman-2.3.16
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
app-emulation/diskimage-builder/Manifest
app-emulation/diskimage-builder/diskimage-builder-2.25.0.ebuild [new file with mode: 0644]
app-emulation/diskimage-builder/diskimage-builder-9999.ebuild

index 6b0c79960875f52882df2468816b3ebe7b1ebb31..515f524bf7101611812fd5d13956db55fe676adb 100644 (file)
@@ -1 +1,2 @@
 DIST diskimage-builder-2.24.0.tar.gz 408702 BLAKE2B 069083aef6214d59d9731a13691c2b48cb354085b698c8f711b3cd93c54d44acb08487510b2b9b038a53c533ea17f41b2521c36eee643c09dc409ea13c21fa6b SHA512 90bf13059f9310f3b45bf7c1a550d837e4d73920efa2af2ae30ec3cd5118d3db223b6953d5209ef0f7029c23f17772de1a36cfba87d7e86bbe8a481aa4ee0639
+DIST diskimage-builder-2.25.0.tar.gz 419297 BLAKE2B 78ac5b1119233080dddef917b05ca4f51f73382bb325cbf228f63837ab79be9ce524351404f2a26cf735440c66a3dc246a1642258b77f217406998650860eb39 SHA512 4afd257b01924a526ef335bf6699f5fbf49ca0c08bb3d288a6823783b842827e3afb51794771994f068332c6ee2ecf6f105fc03112d6a7807932fb5ab1fa4c24
diff --git a/app-emulation/diskimage-builder/diskimage-builder-2.25.0.ebuild b/app-emulation/diskimage-builder/diskimage-builder-2.25.0.ebuild
new file mode 100644 (file)
index 0000000..86d3bb1
--- /dev/null
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_6 python3_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Golden Disk Image builder."
+HOMEPAGE="http://docs.openstack.org/developer/diskimage-builder/"
+if [[ ${PV} == 9999* ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://opendev.org/openstack/diskimage-builder.git"
+else
+       SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+       KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+       !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+       >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+       !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+       >=dev-python/networkx-1.10[${PYTHON_USEDEP}]
+       <dev-python/networkx-2.3[${PYTHON_USEDEP}]
+       >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+       >=dev-python/flake8-2.5.4[${PYTHON_USEDEP}]
+       <dev-python/flake8-2.6.0[${PYTHON_USEDEP}]
+       >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+       >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+       app-emulation/qemu
+       sys-block/parted
+       sys-fs/multipath-tools
+       sys-fs/dosfstools
+       sys-apps/gptfdisk
+       !dev-python/dib-utils[${PYTHON_USEDEP}]"
index bda4c2798bb793b8b46636d97cc7069005829825..86d3bb124b3454a30da00228afaf3b69dc1270e4 100644 (file)
@@ -1,8 +1,8 @@
 # Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
-PYTHON_COMPAT=( python2_7 )
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_6 python3_7 )
 
 inherit distutils-r1