mail-client/neomutt: Remove reserved underscore
authorNicolas Bock <nicolasbock@gentoo.org>
Fri, 25 Oct 2019 14:23:54 +0000 (08:23 -0600)
committerNicolas Bock <nicolasbock@gentoo.org>
Fri, 25 Oct 2019 14:28:30 +0000 (08:28 -0600)
Replace it with `-` in the USE flags.

Package-Manager: Portage-2.3.76, Repoman-2.3.16
Signed-off-by: Nicolas Bock <nicolasbock@gentoo.org>
mail-client/neomutt/metadata.xml
mail-client/neomutt/neomutt-20180716-r1.ebuild [new file with mode: 0644]
mail-client/neomutt/neomutt-99999999.ebuild

index da60d27c6a6590d9b9fe5238298680233b3b880e..74d44a228000e0b15d56d10ff2eb01a559985ae8 100644 (file)
                        header caching</flag>
                <flag name="pgp_classic">Build classic_pgp backend to support PGP/MIME
                        and traditional/inline PGP</flag>
+               <flag name="pgp-classic">Build classic_pgp backend to support PGP/MIME
+                       and traditional/inline PGP</flag>
                <flag name="gpg">Enable support for <pkg>app-crypt/gpgme</pkg></flag>
                <flag name="gpgme">Build gpgme backend to support S/MIME, PGP/MIME and
                        traditional/inline PGP</flag>
                <flag name="smime">Enable support for smime</flag>
                <flag name="smime_classic">Build classic_smime backend to support
                        S/MIME</flag>
+               <flag name="smime-classic">Build classic_smime backend to support
+                       S/MIME</flag>
        </use>
 </pkgmetadata>
diff --git a/mail-client/neomutt/neomutt-20180716-r1.ebuild b/mail-client/neomutt/neomutt-20180716-r1.ebuild
new file mode 100644 (file)
index 0000000..760003e
--- /dev/null
@@ -0,0 +1,130 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils flag-o-matic
+
+if [[ ${PV} =~ 99999999$ ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/neomutt/neomutt.git"
+       EGIT_CHECKOUT_DIR="${WORKDIR}/neomutt-${P}"
+else
+       SRC_URI="https://github.com/${PN}/${PN}/archive/${P}.tar.gz"
+       KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="A small but very powerful text-based mail client"
+HOMEPAGE="https://neomutt.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="berkdb doc gdbm gnutls gpgme idn kerberos kyotocabinet libressl
+       lmdb nls notmuch pgp-classic qdbm sasl selinux slang smime-classic
+       ssl tokyocabinet"
+
+CDEPEND="
+       app-misc/mime-types
+       berkdb? (
+               || (
+                       sys-libs/db:6.2
+                       sys-libs/db:5.3
+                       sys-libs/db:4.8
+               )
+               <sys-libs/db-6.3:=
+       )
+       gdbm? ( sys-libs/gdbm )
+       kyotocabinet? ( dev-db/kyotocabinet )
+       lmdb? ( dev-db/lmdb )
+       nls? ( virtual/libintl )
+       qdbm? ( dev-db/qdbm )
+       tokyocabinet? ( dev-db/tokyocabinet )
+       gnutls? ( >=net-libs/gnutls-1.0.17 )
+       gpgme? ( >=app-crypt/gpgme-0.9.0 )
+       idn? ( net-dns/libidn:= )
+       kerberos? ( virtual/krb5 )
+       notmuch? ( net-mail/notmuch )
+       sasl? ( >=dev-libs/cyrus-sasl-2 )
+       !slang? ( sys-libs/ncurses:0 )
+       slang? ( sys-libs/slang )
+       ssl? (
+               !libressl? ( >=dev-libs/openssl-0.9.6:0 )
+               libressl? ( dev-libs/libressl )
+       )
+"
+DEPEND="${CDEPEND}
+       dev-lang/tcl
+       net-mail/mailbase
+       doc? (
+               dev-libs/libxml2
+               dev-libs/libxslt
+               app-text/docbook-xsl-stylesheets
+               || ( www-client/lynx www-client/w3m www-client/elinks )
+       )"
+RDEPEND="${CDEPEND}
+       selinux? ( sec-policy/selinux-mutt )
+"
+
+S="${WORKDIR}/${PN}-${P}"
+
+src_configure() {
+       local myconf=(
+               "$(use_enable doc)"
+               "$(use_enable nls)"
+               "$(use_enable notmuch)"
+
+               "$(use_enable gpgme)"
+               "$(use_enable pgp-classic pgp)"
+               "$(use_enable smime-classic smime)"
+
+               # Database backends.
+               "$(use_enable berkdb bdb)"
+               "$(use_enable gdbm)"
+               "$(use_enable kyotocabinet)"
+               "$(use_enable qdbm)"
+               "$(use_enable tokyocabinet)"
+
+               "$(use_enable idn)"
+               "$(use_enable kerberos gss)"
+               "$(use_enable lmdb)"
+               "$(use_enable sasl)"
+               "--with-ui=$(usex slang slang ncurses)"
+               "--sysconfdir=${EPREFIX}/etc/${PN}"
+               "$(use_enable ssl)"
+               "$(use_enable gnutls)"
+       )
+
+       econf CCACHE=none "${myconf[@]}"
+}
+
+src_install() {
+       emake DESTDIR="${D}" install
+
+       # A man-page is always handy, so fake one – here neomuttrc.5
+       # (neomutt.1 already exists)
+       if use !doc; then
+               sed -n \
+                       -e '/^\(CC_FOR_BUILD\|CFLAGS_FOR_BUILD\)\s*=/p' \
+                       -e '/^\(EXTRA_CFLAGS_FOR_BUILD\|LDFLAGS_FOR_BUILD\)\s*=/p' \
+                       -e '/^\(EXEEXT\|SRCDIR\)\s*=/p' \
+                       Makefile > doc/Makefile.fakedoc || die
+               sed -n \
+                       -e '/^MAKEDOC_CPP\s*=/,/^\s*$/p' \
+                       -e '/^doc\/\(makedoc$(EXEEXT)\|neomutt\.1\|neomuttrc\.5\)\s*:/,/^\s*$/p' \
+                       doc/Makefile.autosetup >> doc/Makefile.fakedoc || die
+               emake -f doc/Makefile.fakedoc doc/neomutt.1
+               emake -f doc/Makefile.fakedoc doc/neomuttrc.5
+               doman doc/neomutt.1 doc/neomuttrc.5
+       fi
+
+       dodoc LICENSE* ChangeLog* README*
+}
+
+pkg_postinst() {
+       if use gpgme && ( use pgp-classic || use smime-classic ); then
+               ewarn "  Note that gpgme (old gpg) includes both pgp and smime"
+               ewarn "  support.  You can probably remove pgp-classic (old crypt)"
+               ewarn "  and smime-classic (old smime) from your USE-flags and"
+               ewarn "  only enable gpgme."
+       fi
+}
index e97f8da78b1cf2209183b655957b439d4047f912..760003ea0505647d8649afa435996781db3e8b35 100644 (file)
@@ -20,7 +20,7 @@ HOMEPAGE="https://neomutt.org/"
 LICENSE="GPL-2"
 SLOT="0"
 IUSE="berkdb doc gdbm gnutls gpgme idn kerberos kyotocabinet libressl
-       lmdb nls notmuch pgp_classic qdbm sasl selinux slang smime_classic
+       lmdb nls notmuch pgp-classic qdbm sasl selinux slang smime-classic
        ssl tokyocabinet"
 
 CDEPEND="
@@ -74,8 +74,8 @@ src_configure() {
                "$(use_enable notmuch)"
 
                "$(use_enable gpgme)"
-               "$(use_enable pgp_classic pgp)"
-               "$(use_enable smime_classic smime)"
+               "$(use_enable pgp-classic pgp)"
+               "$(use_enable smime-classic smime)"
 
                # Database backends.
                "$(use_enable berkdb bdb)"
@@ -121,10 +121,10 @@ src_install() {
 }
 
 pkg_postinst() {
-       if use gpgme && ( use pgp_classic || use smime_classic ); then
+       if use gpgme && ( use pgp-classic || use smime-classic ); then
                ewarn "  Note that gpgme (old gpg) includes both pgp and smime"
-               ewarn "  support.  You can probably remove pgp_classic (old crypt)"
-               ewarn "  and smime_classic (old smime) from your USE-flags and"
+               ewarn "  support.  You can probably remove pgp-classic (old crypt)"
+               ewarn "  and smime-classic (old smime) from your USE-flags and"
                ewarn "  only enable gpgme."
        fi
 }