Version bump, add patch for compilation with >=2.6.20 kernels.
authorPatrick McLean <chutzpah@gentoo.org>
Wed, 14 Feb 2007 20:25:02 +0000 (20:25 +0000)
committerPatrick McLean <chutzpah@gentoo.org>
Wed, 14 Feb 2007 20:25:02 +0000 (20:25 +0000)
Package-Manager: portage-2.1.2-r9

app-arch/mt-st/ChangeLog
app-arch/mt-st/files/digest-mt-st-0.7-r1
app-arch/mt-st/files/digest-mt-st-0.9b [new file with mode: 0644]
app-arch/mt-st/files/mt-st-0.9b-use-internal-qic117.patch [new file with mode: 0644]
app-arch/mt-st/mt-st-0.9b.ebuild [new file with mode: 0644]

index aa826d56f9d51ee6529a1ba9d174d1116387bee0..ff879a2ccd235dbaa263393e79623be6e7a9c4a7 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for app-arch/mt-st
 # Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/mt-st/ChangeLog,v 1.18 2007/01/05 23:28:52 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/mt-st/ChangeLog,v 1.19 2007/02/14 20:25:02 chutzpah Exp $
+
+*mt-st-0.9b (14 Feb 2007)
+
+  14 Feb 2007; Patrick McLean <chutzpah@gentoo.org>
+  +files/mt-st-0.9b-use-internal-qic117.patch, +mt-st-0.9b.ebuild:
+  Version bump, add patch for compilation with >=2.6.20 kernels.
 
   05 Jan 2007; Danny van Dyk <kugelfang@gentoo.org> -mt-st-0.6.ebuild,
   -mt-st-0.7.ebuild:
index 36a6f6cc8f18536ef6b532d6ed35c5a2880721ed..be462693e5203af7d96d572f622823c38509116e 100644 (file)
@@ -1 +1,3 @@
 MD5 3e1cb5a09dc73c6e54089e2056f9ff55 mt-st-0.7.tar.gz 35529
+RMD160 26574d8d7cbe624037bf0e72098e0b434b963c4b mt-st-0.7.tar.gz 35529
+SHA256 f8b90df763a0b9038edc02985daa0d2728bf004145f1bbc5dcd79fe58f52cba3 mt-st-0.7.tar.gz 35529
diff --git a/app-arch/mt-st/files/digest-mt-st-0.9b b/app-arch/mt-st/files/digest-mt-st-0.9b
new file mode 100644 (file)
index 0000000..a9657f1
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 c80e992a8d16def7af7421549b26ce77 mt-st-0.9b.tar.gz 36537
+RMD160 79a3b9a0a5f88d27c6705ed3eab7462912a1f8ef mt-st-0.9b.tar.gz 36537
+SHA256 40744e23f0a00315062e41eb93482f1d53e035a02cdc7ba726433aea38e1a625 mt-st-0.9b.tar.gz 36537
diff --git a/app-arch/mt-st/files/mt-st-0.9b-use-internal-qic117.patch b/app-arch/mt-st/files/mt-st-0.9b-use-internal-qic117.patch
new file mode 100644 (file)
index 0000000..26fb6e0
--- /dev/null
@@ -0,0 +1,11 @@
+--- mt-st-0.9b/mtio.h.orig     2007-02-14 15:17:55.293052006 -0500
++++ mt-st-0.9b/mtio.h  2007-02-14 15:18:04.623192750 -0500
+@@ -10,7 +10,7 @@
+ #include <linux/types.h>
+ #include <linux/ioctl.h>
+-#include <linux/qic117.h>
++#include "qic117.h"
+ /*
+  * Structures and definitions for mag tape io control commands
diff --git a/app-arch/mt-st/mt-st-0.9b.ebuild b/app-arch/mt-st/mt-st-0.9b.ebuild
new file mode 100644 (file)
index 0000000..f6ba06e
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/mt-st/mt-st-0.9b.ebuild,v 1.1 2007/02/14 20:25:02 chutzpah Exp $
+
+inherit eutils
+
+DESCRIPTION="Enhanced mt command for Linux, supporting Linux 2.4 ioctls"
+HOMEPAGE="http://www.gnu.org/software/tar/"
+SRC_URI="http://www.ibiblio.org/pub/linux/system/backup/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="virtual/libc"
+
+src_unpack() {
+       unpack ${A} || die
+       cd ${S} || die
+       sed -i -e "s:-O2:${CFLAGS}:g" Makefile
+
+       # needed for linux kernels >=2.6.20
+       epatch "${FILESDIR}"/${P}-use-internal-qic117.patch
+}
+
+src_compile() {
+       emake || die
+}
+
+src_install() {
+       dosbin mt stinit || die
+       doman mt.1 stinit.8
+       dodoc README* stinit.def.examples
+}