dev-python/catkin_pkg: bump to 0.4.10
authorAlexis Ballier <aballier@gentoo.org>
Tue, 15 Jan 2019 10:37:47 +0000 (11:37 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Tue, 15 Jan 2019 10:46:45 +0000 (11:46 +0100)
Package-Manager: Portage-2.3.56, Repoman-2.3.12
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
dev-python/catkin_pkg/Manifest
dev-python/catkin_pkg/catkin_pkg-0.4.10.ebuild [new file with mode: 0644]

index eec9b369dd5772cf0471a0e2cedf0cc9aa41a95a..b3c7b434c3bad838112398aaa16fd6c4e3c71372 100644 (file)
@@ -1 +1,2 @@
+DIST catkin_pkg-0.4.10-gh.tar.gz 61272 BLAKE2B e4246d602fd8b8a8b8dda4f412aac4f88ae3328bf2602268566a0f761fa7c435412ae36f563e8082a2e0497c92ca302ea7505dfb32802d3ff00fe4323cd361b1 SHA512 55c2a03c922f647f25e74dce33486d09070c3089dfe2ae26d0673752298d6bb55652b9079b32694c9d80f52ae55fef2fac9f853b6d0b9d6121e6e8c233dc3530
 DIST catkin_pkg-0.4.9-gh.tar.gz 60919 BLAKE2B e7d4987022359fa7306df77ede2e07b2371bfa16b9787e513dd096ffe3988f9b7e6cbf61b96e00992334dadc6052811c20e0b7ea6c9198db332c1eac545c5031 SHA512 53e8440c0768b221526d134c5609c3088dd02e214150253469fe5883665936472486792db2d69c05fd352949f2350bda5960e71cd54e3f1d9164e0915c963295
diff --git a/dev-python/catkin_pkg/catkin_pkg-0.4.10.ebuild b/dev-python/catkin_pkg/catkin_pkg-0.4.10.ebuild
new file mode 100644 (file)
index 0000000..34cb49f
--- /dev/null
@@ -0,0 +1,55 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+       SCM="git-r3"
+       EGIT_REPO_URI="https://github.com/ros-infrastructure/catkin_pkg"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Standalone Python library for the catkin package system"
+HOMEPAGE="http://wiki.ros.org/catkin_pkg"
+if [ "${PV#9999}" != "${PV}" ] ; then
+       SRC_URI=""
+       KEYWORDS=""
+else
+       SRC_URI="https://github.com/ros-infrastructure/catkin_pkg/archive/${PV}.tar.gz -> ${P}-gh.tar.gz"
+       KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       dev-python/docutils[${PYTHON_USEDEP}]
+       dev-python/python-dateutil[${PYTHON_USEDEP}]
+       dev-python/pyparsing[${PYTHON_USEDEP}]
+"
+BDEPEND="
+       test? (
+               dev-python/nose[${PYTHON_USEDEP}]
+       )
+"
+DEPEND="${RDEPEND} ${BDEPEND}
+       test? (
+               dev-python/flake8[${PYTHON_USEDEP}]
+               dev-python/mock[${PYTHON_USEDEP}]
+       )"
+RDEPEND="${RDEPEND}
+       !<dev-util/catkin-0.7.14"
+PATCHES=(
+       "${FILESDIR}/catkin_prefix2.patch"
+       "${FILESDIR}/ros_packages.patch"
+       "${FILESDIR}/infinite_loop3.patch"
+)
+
+python_test() {
+       nosetests -s --tests test || die
+}