x11-themes/e-flat-theme: 2020-04-27 snapshot
authorJoonas Niilola <juippis@gentoo.org>
Mon, 27 Apr 2020 12:12:01 +0000 (15:12 +0300)
committerJoonas Niilola <juippis@gentoo.org>
Mon, 27 Apr 2020 12:20:27 +0000 (15:20 +0300)
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
x11-themes/e-flat-theme/Manifest
x11-themes/e-flat-theme/e-flat-theme-0_pre20200427.ebuild [new file with mode: 0644]

index a38a9712a711925f74f44ba9f1e6b454c3cba217..811a7ffeea96e3af87df0660fbd5f6dc6c25e1e7 100644 (file)
@@ -1 +1,2 @@
 DIST e-flat-theme-0_pre20200401.edj 45838952 BLAKE2B 1f4180b120141c732a3ffacda6075eddb42e23ebf65a89e4f0efa904d52e1dc396c97eb0bd220fbf66d9847c866fd310aefbd48ed1360dbcbe5bbbb37b5bacef SHA512 20bed0c1630375a83db57c9019b8ddfa6302168c66d632b26eb25730cd916dcf5a621c962b4ffe659e8bcb90b555e7eec6a106e8d091e450cf1b58ac3c06a64f
+DIST e-flat-theme-0_pre20200427.edj 45737040 BLAKE2B 2cc6637da79452eb986d256c12037fec32ce86688e634268bf2c01f0507c2778b737fce2f6d92e13ba39a5a249004881f1a3171d2af8506774394459c0a38de6 SHA512 ad96572523c124db4093812eeac539ab2003c4d588b87ed037b52ba1894e47466005634dd3bdd9f2148d0f64f125a86ca5be66a671d03d7cf8829828cb8ee71c
diff --git a/x11-themes/e-flat-theme/e-flat-theme-0_pre20200427.ebuild b/x11-themes/e-flat-theme/e-flat-theme-0_pre20200427.ebuild
new file mode 100644 (file)
index 0000000..1ce5c3e
--- /dev/null
@@ -0,0 +1,43 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A modern, flat theme for Enlightenment WM"
+HOMEPAGE="https://www.enlightenment.org/ https://phab.enlightenment.org/T6726"
+SRC_URI="https://dev.gentoo.org/~juippis/distfiles/${P}.edj"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc x86"
+
+RDEPEND="x11-wm/enlightenment"
+
+S="${WORKDIR}"
+
+src_prepare() {
+       default
+
+       # doins doesn't allow installing straight from DISTDIR.
+       cp "${DISTDIR}"/${P}.edj . || die "Failed to prepare theme file."
+}
+
+src_configure() { :; }
+src_compile() { :; }
+
+src_install() {
+       insinto /usr/share/elementary/themes/
+       newins ${P}.edj flat-0.edj
+}
+
+pkg_postinst() {
+       elog "You'll find e-flat-theme under System themes in theme selector."
+
+       if [[ -n ${REPLACING_VERSIONS} ]]; then
+               ewarn ""
+               ewarn "You're updating flat-0 theme. Please reload Enlightenment"
+               ewarn "through Menu -> Enlightenment -> Restart, or by issuing"
+               ewarn "  enlightenment -restart"
+               ewarn ""
+       fi
+}