dev-python/os-traits: 0.5.0 bup
authorMatthew Thode <prometheanfire@gentoo.org>
Sat, 24 Feb 2018 06:02:34 +0000 (00:02 -0600)
committerMatthew Thode <prometheanfire@gentoo.org>
Sat, 24 Feb 2018 06:02:34 +0000 (00:02 -0600)
Package-Manager: Portage-2.3.19, Repoman-2.3.6

dev-python/os-traits/Manifest
dev-python/os-traits/os-traits-0.5.0.ebuild [new file with mode: 0644]

index b142c421713416ffd3ff08e15d8b85cccb0014cc..ad368a1664605ead0e89c155a1b48c8207edc0e7 100644 (file)
@@ -1 +1,2 @@
 DIST os-traits-0.3.3.tar.gz 17374 BLAKE2B cc5707317448f66aac84e69340dc1923436846553b059753217ae51971289dc2413ce858f46fc809e80b1754c917fd431b4134b3886eaa6ffac81a4962c30730 SHA512 bd8a7a29170aee1be59ed21684ed2a5dbb1440841a54b522bd3ec31ef61c9fd4f6eecca812c8a8b927c285142801c3da190d7bb47c7b315312e10c1c81d50e27
+DIST os-traits-0.5.0.tar.gz 15775 BLAKE2B 288db72d500a3187a8520b9674982f3233f8644a537ec04971453ece394344b7310cbf133785dfee7122e1aeadebee7fd91d18f57a6ccecf0f176fd569b2bfae SHA512 2dd9019b13fc3394bf97fa9ff6c82d02d26dc6ca8ba8b32e619e9f88a9fdee0d3082e3818ca6a51eea9eb45997dfb48eee6976190b27dff6ab5b892747ce2a54
diff --git a/dev-python/os-traits/os-traits-0.5.0.ebuild b/dev-python/os-traits/os-traits-0.5.0.ebuild
new file mode 100644 (file)
index 0000000..9d64835
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="os-traits is a library containing standardized trait strings."
+HOMEPAGE="https://github.com/openstack/os-traits"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+       !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+       ${CDEPEND}"
+RDEPEND="
+       ${CDEPEND}
+       >=dev-python/six-1.10.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+       sed -i '/^hacking/d' test-requirements.txt || die
+       distutils-r1_python_prepare_all
+}