www-apache/mod_h2: 1.15.9 version bump
authorCraig Andrews <candrews@gentoo.org>
Fri, 15 May 2020 13:23:43 +0000 (09:23 -0400)
committerCraig Andrews <candrews@gentoo.org>
Fri, 15 May 2020 13:24:06 +0000 (09:24 -0400)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Craig Andrews <candrews@gentoo.org>
www-apache/mod_h2/Manifest
www-apache/mod_h2/mod_h2-1.15.9.ebuild [new file with mode: 0644]
www-apache/mod_h2/mod_h2-9999.ebuild

index 2ff69a1137029996cad1ebb88e33e82f0bff900a..4c4c3edd7eb73dc8b5a4da5593ce46b7505bba7b 100644 (file)
@@ -1,2 +1,3 @@
+DIST mod_h2-1.15.9.tar.gz 699712 BLAKE2B 035cc7ec8df4727abdd2cb90dfd4c0e6c94dac8a3872122bd3160a594207b7b948278662e8bbe538f736d4981cf6dde3207951f10b0525281f4547603323b604 SHA512 3743d530d2c70577142745046ddcee227b0a8c5e6d42c96d26df71c8c6234ffa20d36fd176c4e8e81a26835669409afb17df018139a7cfebb04748a84a467191
 DIST mod_http2-1.15.7.tar.gz 1042030 BLAKE2B 5252e15fbc71845db557d567daba63452df0693baad18f8b83f937adbd760f1fa931fbf663f1f5ec475760e75fc132fb0de63784e046092669b1d8fb44d96e9a SHA512 effe0a8f41603865a9dceea6fa109a924e6f2f904a2a02ebf10a20e0315f248cfaf91d4b2a0d6168ee94fb0f4af2680a6992c43cc91b0bf47a13d739b4cf9228
 DIST mod_http2-1.15.8.tar.gz 1029471 BLAKE2B 10dcbafeee8be71858f1eace6c65b31d4a06b9598ba0ed8dd0d191c6fa8eb0475e0b9bd9f52a09fdf3430b18c770f0cd41057e9661f252d11df0edab8189cb26 SHA512 47ee0ef6d5e6cdce8b5d35cdca107331378c3d3ccb6d7b6c36eea8e04dda3d5665233aa7834f122d2069d7c81a833bff08e3f0a279d4a5a0bd1ec6b366696fd3
diff --git a/www-apache/mod_h2/mod_h2-1.15.9.ebuild b/www-apache/mod_h2/mod_h2-1.15.9.ebuild
new file mode 100644 (file)
index 0000000..b158648
--- /dev/null
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit apache-module autotools
+
+MY_P="${PN/h2/http2}-${PV}"
+
+if [[ ${PV} == 9999 ]] ; then
+       EGIT_REPO_URI="https://github.com/icing/mod_h2.git"
+       inherit git-r3
+else
+       S="${WORKDIR}/${MY_P}"
+       SRC_URI="https://github.com/icing/mod_h2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="HTTP/2 module for Apache"
+HOMEPAGE="https://github.com/icing/mod_h2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="ssl"
+
+RDEPEND=">=net-libs/nghttp2-1.0
+       >=www-servers/apache-2.4.20[-apache2_modules_http2,ssl?]"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${P}"
+
+need_apache2_4
+
+src_prepare() {
+       default
+       eautoreconf
+}
+
+src_compile() {
+       default
+}
+
+src_install() {
+       default
+
+       APACHE2_MOD_DEFINE="HTTP2"
+       insinto "${APACHE_MODULES_CONFDIR}"
+       newins "${FILESDIR}/mod_http2.conf" "41_mod_http2.conf"
+}
index 7a124f105c05089d5c68fb4e8ad36fab96501b12..b158648fdb59ff664c300f4e7de97f009e5a9514 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="6"
@@ -12,7 +12,7 @@ if [[ ${PV} == 9999 ]] ; then
        inherit git-r3
 else
        S="${WORKDIR}/${MY_P}"
-       SRC_URI="https://github.com/icing/mod_h2/releases/download/v${PV}/${MY_P}.tar.gz"
+       SRC_URI="https://github.com/icing/mod_h2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
        KEYWORDS="~amd64 ~x86"
 fi
 
@@ -27,6 +27,8 @@ RDEPEND=">=net-libs/nghttp2-1.0
        >=www-servers/apache-2.4.20[-apache2_modules_http2,ssl?]"
 DEPEND="${RDEPEND}"
 
+S="${WORKDIR}/${P}"
+
 need_apache2_4
 
 src_prepare() {