Version bump.
authorDaniel Pielmeier <billie@gentoo.org>
Tue, 18 Oct 2011 18:43:29 +0000 (18:43 +0000)
committerDaniel Pielmeier <billie@gentoo.org>
Tue, 18 Oct 2011 18:43:29 +0000 (18:43 +0000)
Package-Manager: portage-2.1.10.29/cvs/Linux i686

dev-libs/libburn/ChangeLog
dev-libs/libburn/libburn-1.1.6.ebuild [new file with mode: 0644]
dev-libs/libisofs/ChangeLog
dev-libs/libisofs/libisofs-1.1.6.ebuild [new file with mode: 0644]

index 59d8d6c4b3c09dae1949158d211ac70bc4024f47..35f301add23cc8367ed7969849ab6875bc220a49 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for dev-libs/libburn
 # Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libburn/ChangeLog,v 1.100 2011/08/08 17:24:49 billie Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libburn/ChangeLog,v 1.101 2011/10/18 18:41:04 billie Exp $
+
+*libburn-1.1.6 (18 Oct 2011)
+
+  18 Oct 2011; Daniel Pielmeier <billie@gentoo.org> +libburn-1.1.6.ebuild:
+  Version bump.
 
 *libburn-1.1.4 (08 Aug 2011)
 
diff --git a/dev-libs/libburn/libburn-1.1.6.ebuild b/dev-libs/libburn/libburn-1.1.6.ebuild
new file mode 100644 (file)
index 0000000..58fe1b5
--- /dev/null
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libburn/libburn-1.1.6.ebuild,v 1.1 2011/10/18 18:41:04 billie Exp $
+
+EAPI=4
+
+DESCRIPTION="Libburn is an open-source library for reading, mastering and writing optical discs."
+HOMEPAGE="http://libburnia-project.org"
+SRC_URI="http://files.libburnia-project.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE="debug static-libs track-src-odirect"
+#IUSE="cdio debug static-libs track-src-odirect"
+#Supports libcdio but needs version >=0.83 which is not yet released.
+
+RDEPEND=""
+#RDEPEND="cdio? ( >=dev-libs/libcdio-0.83 )"
+DEPEND="dev-util/pkgconfig"
+
+src_configure() {
+       econf \
+       $(use_enable static-libs static) \
+       $(use_enable track-src-odirect) \
+       --disable-libcdio \
+       --disable-ldconfig-at-install \
+       $(use_enable debug)
+#      $(use_enable cdio libcdio) \
+}
+
+src_install() {
+       default
+
+       dodoc CONTRIBUTORS doc/comments
+
+       cd "${S}"/cdrskin
+       docinto cdrskin
+       dodoc changelog.txt README wiki_plain.txt
+       docinto cdrskin/html
+       dohtml cdrskin_eng.html
+
+       find "${D}" -name '*.la' -exec rm -rf '{}' '+' || die "la removal failed"
+}
index d5b5d1ff9c7aa61434300c4acd160a4a286e8802..37ed90534f674f62f508a7933cb5cc60d28964f8 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for dev-libs/libisofs
 # Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libisofs/ChangeLog,v 1.89 2011/08/08 17:26:19 billie Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libisofs/ChangeLog,v 1.90 2011/10/18 18:43:29 billie Exp $
+
+*libisofs-1.1.6 (18 Oct 2011)
+
+  18 Oct 2011; Daniel Pielmeier <billie@gentoo.org> +libisofs-1.1.6.ebuild:
+  Version bump.
 
 *libisofs-1.1.4 (08 Aug 2011)
 
diff --git a/dev-libs/libisofs/libisofs-1.1.6.ebuild b/dev-libs/libisofs/libisofs-1.1.6.ebuild
new file mode 100644 (file)
index 0000000..c8d305d
--- /dev/null
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libisofs/libisofs-1.1.6.ebuild,v 1.1 2011/10/18 18:43:29 billie Exp $
+
+EAPI=4
+
+DESCRIPTION="libisofs is an open-source library for reading, mastering and writing optical discs."
+HOMEPAGE="http://libburnia-project.org/"
+SRC_URI="http://files.libburnia-project.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE="acl debug static-libs verbose-debug xattr zlib"
+
+RDEPEND="acl? ( virtual/acl )
+       xattr? ( sys-apps/attr )
+       zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+       dev-util/pkgconfig"
+
+src_configure() {
+       econf \
+       $(use_enable static-libs static) \
+       $(use_enable debug) \
+       $(use_enable verbose-debug) \
+       $(use_enable acl libacl) \
+       $(use_enable xattr) \
+       $(use_enable zlib) \
+       --disable-libjte \
+       --disable-ldconfig-at-install
+}
+
+src_install() {
+       default
+
+       dodoc Roadmap doc/{checksums.txt,susp_aaip*,Tutorial,zisofs_format.txt}
+
+       find "${D}" -name '*.la' -exec rm -rf '{}' '+' || die "la removal failed"
+}