Version bump for ruledispatch dependency
authorTiziano Müller <dev-zero@gentoo.org>
Wed, 28 Feb 2007 00:18:29 +0000 (00:18 +0000)
committerTiziano Müller <dev-zero@gentoo.org>
Wed, 28 Feb 2007 00:18:29 +0000 (00:18 +0000)
Package-Manager: portage-2.1.2-r10

dev-python/pyprotocols/ChangeLog
dev-python/pyprotocols/files/digest-pyprotocols-1.0_pre2082 [new file with mode: 0644]
dev-python/pyprotocols/pyprotocols-1.0_pre2082.ebuild [new file with mode: 0644]

index 89c010d1e4a1cbf591f558147055fd7d12d3a0be..a87005bb9a3a56864a9956b3bddc1e3199164cfb 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for dev-python/pyprotocols
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyprotocols/ChangeLog,v 1.8 2007/01/19 00:19:18 lucass Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyprotocols/ChangeLog,v 1.9 2007/02/28 00:18:29 dev-zero Exp $
+
+*pyprotocols-1.0_pre2082 (28 Feb 2007)
+
+  28 Feb 2007; Tiziano Müller <dev-zero@gentoo.org>
+  +pyprotocols-1.0_pre2082.ebuild:
+  Version bump for ruledispatch dependency
 
   19 Jan 2007; Lukasz Strzygowski <lucass@gentoo.org>
   -pyprotocols-0.9.2.ebuild:
diff --git a/dev-python/pyprotocols/files/digest-pyprotocols-1.0_pre2082 b/dev-python/pyprotocols/files/digest-pyprotocols-1.0_pre2082
new file mode 100644 (file)
index 0000000..a903811
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 11c5871560b65cf72b45845013297b94 PyProtocols-1.0a0dev_r2082.zip 124061
+RMD160 c7bb73f42d8f35bb481b1ecc9a23f85e78d10eea PyProtocols-1.0a0dev_r2082.zip 124061
+SHA256 fb8b9a3db25e0b447fbf327c26b859368cefdc14438b9752ab248b788f119016 PyProtocols-1.0a0dev_r2082.zip 124061
diff --git a/dev-python/pyprotocols/pyprotocols-1.0_pre2082.ebuild b/dev-python/pyprotocols/pyprotocols-1.0_pre2082.ebuild
new file mode 100644 (file)
index 0000000..09d1619
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyprotocols/pyprotocols-1.0_pre2082.ebuild,v 1.1 2007/02/28 00:18:29 dev-zero Exp $
+
+NEED_PYTHON=2.4
+
+inherit distutils
+
+KEYWORDS="~amd64 ~x86"
+
+MY_PN=PyProtocols
+MY_P=${MY_PN}-${PV/_pre/a0dev_r}
+
+DESCRIPTION="Extends the PEP 246 adapt() function with a new 'declaration API' that lets you easily define your own protocols and adapters, and declare what adapters should be used to adapt what types, objects, or protocols."
+HOMEPAGE="http://peak.telecommunity.com/PyProtocols.html"
+SRC_URI="http://peak.telecommunity.com/snapshots/${MY_P}.zip"
+LICENSE="|| ( PSF-2.4 ZPL )"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-python/setuptools
+       app-arch/unzip"
+RDEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+PYTHON_MODNAME="protocols"
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+       sed -i \
+               -e '/ez_setup/d' \
+               -e '/install_requires = \[.*\],/d' \
+               -e '/install_requires/, /],/d' \
+               setup.py || die "sed failed"
+}