net-news/snownews: fix compilation with ncurses
authorHans de Graaff <graaff@gentoo.org>
Mon, 16 Sep 2019 18:08:58 +0000 (20:08 +0200)
committerHans de Graaff <graaff@gentoo.org>
Mon, 16 Sep 2019 18:09:36 +0000 (20:09 +0200)
This package now requires unicode support for ncurses,
otherwise compilation will fails. Fix the pkgconfig handling,
drop the unicode USE flag and always require unicode support.

Fixes: https://bugs.gentoo.org/690224
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
net-news/snownews/snownews-1.6.10.ebuild

index c718b5a16d649e4287e6811dbd26bf7b64cd94fc..e05f9d4fe085a571f153055bdcf1d35d879f7891 100644 (file)
@@ -11,11 +11,11 @@ SRC_URI="https://github.com/kouya/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
 LICENSE="GPL-3"
 SLOT="0"
 KEYWORDS="amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
-IUSE="unicode"
+IUSE=""
 
 COMMON_DEPEND="
        >=dev-libs/libxml2-2.5.6
-       >=sys-libs/ncurses-5.3:0=[unicode?]
+       >=sys-libs/ncurses-5.3:0=[unicode]
 "
 RDEPEND="
        ${COMMON_DEPEND}
@@ -32,7 +32,8 @@ BDEPEND="virtual/pkgconfig"
 src_prepare() {
        default
        tc-export PKG_CONFIG
-       sed -i 's|-lncurses|`\\$(PKG_CONFIG) --libs '"$(usex unicode ncursesw ncurses)"'`|' configure || die
+       local libs=$(${PKG_CONFIG} --libs ncursesw)
+       sed -i "s|-lncursesw\?|${libs}|" configure Config.mk.in || die
        sed -i 's|$(INSTALL) -s snownews|$(INSTALL) snownews|' Makefile || die
 }