dev-ml/llvm-ocaml: Use BDEPEND semi-properly
authorMichał Górny <mgorny@gentoo.org>
Tue, 17 Sep 2019 21:00:09 +0000 (23:00 +0200)
committerMichał Górny <mgorny@gentoo.org>
Tue, 17 Sep 2019 21:00:45 +0000 (23:00 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-ml/llvm-ocaml/llvm-ocaml-10.0.0.9999.ebuild
dev-ml/llvm-ocaml/llvm-ocaml-9.0.0.9999.ebuild

index f8d000150fbbc40d52d67a6d4d613add56372ac8..3fd5dbb40b8e840fae4ba9b7be1aae05f22298d3 100644 (file)
@@ -35,8 +35,9 @@ RDEPEND="
        dev-ml/ocaml-ctypes:=
        ~sys-devel/llvm-${PV}:=[${LLVM_TARGET_USEDEPS// /,},debug?]
        !sys-devel/llvm[ocaml(-)]"
+DEPEND="${RDEPEND}"
 # configparser-3.2 breaks the build (3.3 or none at all are fine)
-DEPEND="${RDEPEND}
+BDEPEND="
        dev-lang/perl
        dev-ml/findlib
        test? ( dev-ml/ounit )
index f41bee81c8c377014e95b552e8ff367f2c82e089..fad71890f1af865e2861dd233ee823d3d6ce8695 100644 (file)
@@ -34,8 +34,9 @@ RDEPEND="
        dev-ml/ocaml-ctypes:=
        ~sys-devel/llvm-${PV}:=[${LLVM_TARGET_USEDEPS// /,},debug?]
        !sys-devel/llvm[ocaml(-)]"
+DEPEND="${RDEPEND}"
 # configparser-3.2 breaks the build (3.3 or none at all are fine)
-DEPEND="${RDEPEND}
+BDEPEND="
        dev-lang/perl
        dev-ml/findlib
        test? ( dev-ml/ounit )