Fix regex, bug 269557, thanks to Samuli Suominen <ssuominen@gentoo.org>.
authoridl0r <idl0r@gentoo.org>
Tue, 12 May 2009 18:14:43 +0000 (18:14 -0000)
committeridl0r <idl0r@gentoo.org>
Tue, 12 May 2009 18:14:43 +0000 (18:14 -0000)
svn path=/trunk/gentoolkit-dev/; revision=638

src/echangelog/echangelog

index e2886508178095a682d9f31a62d801b2e3010691..cd31eb288731787c7bbb111fbc50a7f5c3bac3c2 100755 (executable)
@@ -166,6 +166,15 @@ sub update_cat_pn {
        return $t;
 }
 
+# Just to ensure we don't get duplicate entries.
+sub mypush(\@@) {
+       my $aref = shift;
+
+       foreach my $value (@_) {
+               push(@{$aref}, $value) if !grep(/^\Q$value\E$/, @{$aref});
+       }
+}
+
 GetOptions(
        'help' => \$opt_help,
        'strict' => \$opt_strict,
@@ -426,15 +435,6 @@ sub sortfunc($$) {
        return 0;
 }
 
-# Just to ensure we don't get duplicate entries.
-sub mypush(\@@) {
-       my $aref = shift;
-
-       foreach my $value (@_) {
-               push(@{$aref}, $value) if !grep(/^$value$/, @{$aref});
-       }
-}
-
 # Forget ebuilds that only have changed copyrights, unless that's all
 # the changed files we have
 @ebuilds = grep /\.ebuild$/, @files;